
Alpha Anywhere Web & Mobile Made Easy,  
The Basics and More for Version 12 Volume 1 

To: Hard copy owners of the above book. 

Re: Update to Alpha Anywhere v 3.0 

We have repackaged the above book with a new cover and some bug fixes. The edits are 
reprinted here for owners of the hard copy edition. We suggest your print them out, insert the 
revised pages in your book and make the corrections noted below. 

Overview: 

Chapter 2: Readers became confused when they got to page 72 because they could not find the 
web project referenced. This was because the instructions for opening the companion database 
were omitted at the beginning of the chapter.  

Chapter 9: The Video Finder has been revised. We have included the entire chapter here, 
although only the section on the Video Finder has been updated. 

Miscellaneous Fixes. Please correct your book as follows: 

Page 31 & 32 
There are two errors that cause confusion between Order and Filter. 
Page 31. Screen shot should show the lastname entry in the Order textbox (not Filter). 
Page 32. Step i: Double click Lastname to place it in the Filter window. Should say place it in 
the Order window. 
(Thanks to Jack Poronsky & Matthew Fleck) 

Page 40:  
Step 29: Should say: Project: Select the default, MyMailingList (not MailingList). 
(Thanks to Jack Poronsky) 

Page 120 (top of page): 
The report is in the MailingList project and must be copied into the MyMailingList project. 
Step 16: Go to the MailingList project > Reports (inset). 
   a. Select CustomersByState.a5rpt: Right click > Copy To. 
   b. Destination project: Choose MyMailingList. (Click OK) 
   c. Return to the MyMailingList project > Reports. 
Continue with step 17 as directed. 
(Thanks to Ron Schectman) 

Page 144:  
Please note that the template expression goes over to the next page. Easy to miss, as Stephen 
discovered. 
(Thanks to Stephen Attwood) 



Page 151:  
Step i: Prior to selecting Animation Type, you need to check (yes) to Animation (otherwise you 
don't see the Animation Type option. 
(Thanks to Stephen Attwood) 

Page 152:  
Go to Alpha video is on page 148 (not page 152). 
(Thanks to Stephen Attwood) 

Page 158:  
Step 24 i: Code should be {Grid.ChildObject}.clearVideo(); (not .closeVideo) 
(Thanks to Ron Schectman) 

 



 Chapter 2.

Marvelous Moves

Hop on the carpet…

And we’ll take you on an truly magical ride. Once you do these exercises, you’ll
understand how the basic elements of Alpha Anywhere web and mobile application
design fit together…

And, when you’re finished, you’ll have your first web application!
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Using Alpha Anywhere Help

This chapter references several Alpha Anywhere help documents and videos. Using the help system is
fully explained in Chapter 9. We suggest you look it over, if you have not already done so.

In the meantime, when you see a reference, do the following:

• With Alpha Anywhere open, 

1. Click on either Documentation or Videos on the main toolbar.

• Available at the Control Panel and Web Projects Control Panel.

2. Filter: Enter the page or video name.

Note: The revised Video Finder is explained at “Using the Video Finder” on page 462. The “Categories”
pane was added after most of this book was written. In the interests of time, we have left them as they are.
Remember that you can always enter the first part of the video number in the Filter if you have any difficulty
locating one that has been referenced. For example, 

To find video number UXG_V12-2, enter UXG_V12 and choose from the selection.

Screen shots:  For reasons of space economy, blank areas have been removed from screen shots. In many
cases, the OK and Cancel buttons have also been cropped.

Data paths:  File locations on the development computer may be different than yours. To avoid confusion,
the data path has been struck out in some of the screen shots. Just follow the instructions to get to the right
place.

Note to readers of previous editions: While this chapter uses the same title as in previous books (V11 and
earlier), the material is different in that it uses SQL as the data source and the Image Gallery component and a
Tree Navigator have been added. It also places the elements in a Tabbed UI component, rather than on an .a5w
page. In other words, be sure not to skip it!
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How the material is organized

In order to have a sense of how Alpha Anywhere web applications work, it is
important to see the system in action. This chapter will teach the following pro-
cedures:

a. Creating, previewing and several web components.

b. Using a Tabbed UI component to ready them for the web.

WHO NEEDS THIS? Almost all the material in this book applies to web applications, but not
everything is suitable for mobile applications. As we go along, we will let you
know what works where. In the case of this chapter, the exercises focus on the
Grid, which is used for web applications, however, certain principles are
explained that everyone needs to know. So, we will mark it:

• Web & Mobile.

VIDEO! SEE P. 37, 41, 53,
49.

There are four videos that give a general idea of how a grid component
works. You may want to watch them before beginning this chapter. The videos
were done for V10, so, in some cases, they don’t show all features now avail-
able but the concepts are still valid.

SQL AND DBF The process of creating Alpha Anywhere applications is the same for all
users, with a few minor exceptions. For the exercises in this book, we will use
both file types, however we will concentrate on SQL since, as we saw in Chap-
ter 1, it is the recommended type.

Understanding Workspaces

Alpha Anywhere has a desktop side and a web/mobile side. On the desktop
side, it can be used to create stand-alone desktop databases. On the web/mobile
side, it can connect to data in any format to produce applications for on-line use.
These environments are called Workspaces.

Once Alpha Anywhere is opened, you can go back and forth between them
or stay in one or the other. We will be working on the web/mobile side so that
will be the focus of this book.

1. Open Alpha Anywhere.

2. Navigate to the companion workspace for this book. Default location:

• c:\Alpha_WebMobileBook_3.0_Volume1\ ABC_WebMobile_Les-
sons \ ABC Seminars
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Dialog Title: Select Workspace - News & Updates

3. At the Welcome Screen (left), click the
Workspace & Tasks tab.

• If you do not see this screen, click the 
Recent Workspaces button (red box).

Dialog Title: Select Workspace - Workspace & Tasks

APPLICATION TYPES
As we have said, Alpha Anywhere can build
desktop, web and mobile applications. The
latter are developed in the same workspace,
so they are combined into a single choice.

Choosing web/mobile or desktop here does not remove any functionality.
Both will still be available. The option is presented so those interested in devel-
oping only one or the other can head directly to that workspace.

• When both options are selected, the program will open on the desk-
top side.

While we will only be building Web/Mobile applications in this book, we
want you to understand navigation between the two workspaces. At a later time,

you can choose just Web/Mobile if you like.*

4. Types of Applications you want to build: Check both Web/Mobile and
Desktop.

5. Choose Open an existing Workspace > More Workspaces…

6. Navigate to c:\Alpha_WebMobileBook_3.0_Volume1 \ 
ABC_WebMobile_Lessons \ ABC Seminars.

7. Click Open.

*. You can always change this later. Click the Control Panel button and go to: Top Menu > File > Workspace Properties.
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• You are taken to the ABC Seminars main menu on the Desktop side 
of Alpha Anywhere.

8. Navigate to the Control Panel in one of these three ways:

• Click Activate the Control Panel (red circle – top of screen).

• Click the Control Panel tab (yellow – bottom of screen).

• Click on the Control Panel itself (gold arrow).

9. At the Control Panel, click the Web Projects button.

• You are taken to the Web Projects Control Panel where BOTH Web 
and Mobile applications are developed.



 Chapter 9.

Heavenly Help Plus!

Ordinary help is old school …

Alpha Anywhere help is one of the best we’ve seen. It puts the extraordinary
number of help topics and videos at your fingertips. 

The newly revised Video Library uses the List Control to make it easy to find
just what you’re looking for. Definitely a plus!



CHAPTER 9. HEAVENLY HELP PLUS!
 

450

What you’ll find here…

Topic Page

“How the material is organized” 451

“Understanding the Documentation Viewer (DV)” 452

“Getting off to a strong start” 452

“Display and navigation” 452

“Searching for topic pages” 454

“Saving page references” 457

“Taking Notes” 458

“Printing topics” 460

“Updating the documentation” 460

“Window style” 461

“Restoring open pages” 461

“Sending feedback” 461

“Using the Video Finder” 462

“Filtering” 462

“Refreshing” 463

“Preferences” 463

You may have seen this chapter before because we add it to almost all
our books – it’s that important!

But. Don’t run off. There’s new information on using the Video Library, so
be sure to look it over (page 462).
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How the material is organized

Being able to get assistance as you work is essential to using any feature
laden program like Alpha Anywhere. The good news is that there is so much
documentation. The bad news is that there is so much documentation because
the sheer volume can be overwhelming.

Fortunately, the Documentation Viewer (DV) and Video Finder (VF) will get
you where you want to be. These are both opened within Alpha Anywhere.

You can:
•Add notes to any topic.
•Print a single page or multiple pages to a PDF document. 
•Save to lists. 
•Search for topics by keyword, full text and multiple criteria. 
•Update topic pages with the click of a button.

And. Much of the help system can be used without an Internet connection. That
means you can keep working on an airplane or other non-Internet location.
There are two exceptions, however:

•DV: Images do require an Internet connection at first, but are cached 

locally once a topic has been viewed.1

•VF: You will need an Internet connection to view the videos.

The Documentation Viewer and Video Finder will find all the references
seamlessly – and you won’t even have to leave the Alpha Anywhere environ-
ment. The Documentation and Videos buttons are on the main toolbar and are

available at either the Web Projects Control Panel or the Control Panel.2

WHERE DO I LOOK? The Video Finder is the first place to look for web and mobile coverage. The
Documentation Viewer also contains many useful pages, so be sure to go there
for additional information.

Why Plus? You may be wondering why we entitled this chapter Heavenly
Help Plus. The answer is that there’s been an improvement to the Video Finder
that you will really appreciate. Finding videos is easier than ever, now.

1. See “Image display” on page 452.

2. As we go to press, the Videos button is not in the latest software update, so you may not be able to see it. If that is the case, go to Top 
Menu > Help > Video Finder. We have been advised that the button will appear in the next release. SHB 10.5.2012
451
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Understanding the Documentation Viewer (DV)

The Documentation Viewer and Video Finder are separate systems. Since
there are so many documents on so many topics, it has a more complex struc-
ture. 

Getting off to a strong start
We recommend you watch the following videos to learn how to use the Doc-

umentation Viewer. Our notes will be available for a quick refresher, but they
depend on your having watched the videos. It will be 20 minutes well spent –

promise!1

1. Open Alpha Anywhere.

2. Click the Documentation button on the main toolbar.
•Once it opens, the DV has its own toolbar (shown below in two sec-

tions).

3. Click How to use the Documentation Viewer (far right).
•The Documentation Viewer page opens. It gives a list of the features 

and has 4 videos. You may need to scroll down to find them.

•Video Part 1: Overview, Navigating, Filtering.

•Video Part 2: Filtering (cont), Saving Lists, MDI & Modeless views, 
Properties.

•Video Part 3: Synchronize with 2 monitors, Browser-like experience, 
Links to Wiki, Printing to PDF.

•Video Part 4: Favorites, Annotating help documents (Notes).

• Now that you have watched the videos, you know how the system works so 
please read over the rest of this chapter. You can come back here for the set-
tings as you need them.

And. We have included additional information that you will find valuable.

Display and navigation

IMAGE DISPLAY We mentioned earlier that the DV can be used without an Internet connec-
tion. This is true for the most part. One exception is that, the first time a page is
displayed, an Internet connection is required in order to see the images.

• Once the page has been displayed with an Internet connection, the images 
are downloaded from the server and cached locally. Therefore, the next time 

1. Sorry if I sound like your mother here - but, you gotta to do your homework - now! SHB
452
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that particular page is opened, the images will be displayed even when you 
are not on-line.

ENLARGING THE VIEWING 
AREA

There are two ways to give more room on the screen.
•Width: Do this give more width to the topic pages:

•Click the Show/hide Selector button on the toolbar to close the left 
panel.

•Height: If you have a document or list that is very long, it can some-
times be difficult to see the bottom of the scroll bar. Solution: Close 
the tabs at the bottom of the window.

•Top Menu > View: Turn off Window Bar.

OPENING PAGES Topic pages are opened by selecting an item from the left pane.
•One click open: Each time you select a topic in the list, its page is 

opened in the right pane.
•Viewing open pages: When 

you have a lot of pages 
open, do the following:

a. Click the arrow at the 
right side of the tabs for 
a list (red circle). 

b. Select the page.

c. Click OK.

•One page is always open. The system requires that at least one page 
be open at all times. To close unwanted pages, see “Closing pages” 
below.

NAVIGATING As you saw in the video, it is easy to get around using the back, next, up and
down arrows. 

•Back and next arrows: Moves back and forth between pages.
•Up and down arrows: Moves up and down on the list.

•When you use these to move to a new topic in the list, the page is also 
opened. Handy for opening a group of pages that are listed sequentially.

CLOSING PAGES You can close an individual topic page or several at a time.
•Closing selected pages: When you have a lot of pages open, do the 

following:

a. Click the arrow at the right side of the tabs for a list (red circle 
above). 

b. Select the pages you would like to close. 

c. Click Close selected topics.

•Closing a single page. 

a. Right click on the tab and 
choose Close this Tab.
453
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•Closing all except current page:

b. Select the page you want to keep open.

c. Right click on the tab and choose Close all but this tab.

BREADCRUMBS Breadcrumbs show where the page is located within the Alpha Anywhere
Wiki structure. By default, you will find them at the top of the topic page as
below. You may turn them off or have them appear elsewhere, if you like.

We recommend you keep them on, at least in the beginning, because they can
be handy for navigating upwards in the structure. In the example below, you
could click on References or Functions for additional references. 

We suggest you experiment. Sometimes the links are useful, other times not.

a. Preferences > Show topic path: 
Yes or No.

b. Preferences > Topic path posi-
tion: Choose: Above, Below or 
Above and Below.

Searching for topic pages
There are several ways to find documents. You can search by page title, by

text in the topic, or use multiple criteria. Other aids include the Table of Con-
tents and Search Results tabs. If you have a second monitor, you will be inter-
ested in synchronized searching. We have also included notes on using help
inside the Expression Builder.

FILTER BY TITLE Finds all occurrences in the document title.

a. Type: Choose Filter (red circle below).

b. Enter trim in the filter box.

c. Select TRIM Function.

•Trim() will not return any 
results because the title of the 
page is TRIM Function (pink), 
not TRIM() as you might 
think.

• Now, let’s see what happens when we change to full text search.

FULL TEXT SEARCH Finds every occurrence of the entry – full or partial word, highlighted in red.
•When you select Full text search, a Go button appears.

a. Type: Click Full text search (gold 
arrow).

b. Click Go (red circle).

•Alpha Anywhere automatically 
opens the Search Results tab.
•Returns 204 pages.

c. Select a document and scroll to see the 
highlighted text.
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MULTIPLE SEARCH 
CRITERIA

Finds instances of up to five designations. Results are shown in the Search
Results tab as above.

•Wildcards * and ? are permitted, such as SQL*Select*Statement (finds 
only records with all entries). 

•Found text is highlighted in red as above.

a. Click the Search button on the toolbar.

b. Enter trim and cdate in the first two boxes.

•The expression is returned at the bottom of 
the window (pink).
•Finds documents that contain both criteria.

c. Click OK.

•The search begins immediately.
•13 documents are returned at the Search 
Results tab (inset).

d. Click Search again.

e. Enter trim or cdate. (Click OK)

•Click And and change to Or.

•Finds documents that have either trim or cdate.

•This time 213 documents are returned.

f. Inspect a few to see how selections were made.

Now would be a good time to experiment with some more searches so you
get a good sense of how everything works. Will save you time down the road.

TABLE OF CONTENTS TAB The Table of Contents tab shows the search criteria in a tree format. We
entered grid component in the Filter to get the result below. 

•Drilling down the various sections, opens the page references.
•The TOC can be useful for finding topics in a very long list.
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•When a topic is selected in the TOC, the selection is refelected in the 
Topic List (inset) and vice versa.

SEARCH RESULTS TAB Each time you do a Full text or Multiple criteria search, the results are dis-
played in the Search Results tab. 

•When you first open the DV, there is no Search tab.
•When you do a Full text search or use the Search button for multiple 

criteria, the tab is automatically opened and the results displayed.
•Each new search replaces the previous one.
•When you close the DV, the search contents are cleared.

SYNCHRONIZED SEARCH Video #3 explains Synchronized Searches very well so we’ll save a few trees
and skip it here except to note that, if you are in the process of learning Xbasic
and/or are serious about writing code and don’t yet have a second monitor, this
just might be the time to get one.

a. To turn it on, click Preferences on the toolbar.

b. Synchronize help on current function: Yes.

•Default = No.

FUNCTION HELP IN THE 
EXPRESSION BUILDER

When writing expressions in the builder, you can get function help by press-
ing F1 or clicking Help on Current Function. This will bring up the Documen-
tation Viewer page. If you only have one monitor, you will need to close the
page before continuing with the expression. 

Here’s a work around for keeping the page open.

a. At the Expression Builder, place the cursor in 
the middle of the Function (upper).

•The full function, complete with the 
opening parenthesis, needs to be entered in 
order for this to work. Just begin typing 
and pick it from the suggestions.
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b. Click the Help on Current Function button or 
press F1.

HOW EB HELP WORKS
The Expression Builder is opened in a
“modal” window. That means you can’t
move to another window when it is open.
When you go to help from within the EB, the
Documentation Viewer opens in yet another
modal window that must be closed in order to
continue.

KEEPING FUNCTION HELP OPEN
If you would like to keep Function Help open
while you continue to work in the Expression
Builder: 

c. Click the link at the bottom of the DV page 
(yellow) to open the document in the Wiki.

•You can then work back and forth between 
Alpha Anywhere and the page in the Wiki.

Saving page references
You can save page references so you can return to them quickly. There are

two ways, Favorites and Lists. The first is a simple listing of pages, the latter
groups multiple pages.

FAVORITES It’s quick and easy to save your frequently used topics in Favorites. At this
writing, topics are added in the order saved – most recent at the bottom – and
there is no way to group or alphabetize them, so a long list could become
unwieldy. Keep Favorites short and use Lists (below) for more lengthy topics.

a. Filter: Enter trim.

•5 topics are returned.

b. Select a topic in the list: Right click > 
Add to Favorites.

c. Go to the Favorites tab to see the entry 
(green).

LISTS Lists are great for saving groups of pages. The important thing to remember
is that they save the open pages – not items in the Topic List (see screen shot
below). 

a. Filter: Enter trim.
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•5 topics are returned.

b. Click the last topic in the list.

c. Right click on the Trim page and select Close all but this tab.

SAVING

a. Click Save the current list of 
open topics … on the toolbar (red 
circle).

b. Name of list: Trim.

c. Click OK.

RETRIEVING a. Click Open a previously saved list of topics (red circle).

b. Select Trim.

•Note that Topics in List contains only the open page (inset above).

ADDING PAGES Pages can be added to a list. This operation overwrites the existing list. In
order to add pages, you need to open the original list first.

a. Click Open a previously saved list of topics.

b. Name of list: Choose the List. (Click OK)

•The original pages in the list are now open in the right pane.

c. Open the new pages you want to add.

d. Click Open a previously saved list of topics again.

e. Name of list: Choose the List.

f. Click OK.

•Alpha Anywhere recognizes that you have changed the list and 
asks if you want to overwrite.

g. Overwrite existing list? Click OK.

DELETING PAGES Pages can be deleted in the following manner.

a. Click Open a previously saved list of topics.

b. Name of list: Choose the List. 

c. Click Edit List at bottom of dialog.

d. Delete the pages you want to remove.

e. Click OK twice.

Taking Notes
Notes are well described in Video #4. Here are the settings and some addi-

tional thoughts.

ADD NOTE TO EXISTING 
PAGE

You can annotate any page. Depending on where you have located the notes,
these may or may not be shared with a work group (see “Notes directory” on
page 459).

a. Enter trim in the Filter box.
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b. Select TRIM Function.

c. Click Notes on the toolbar.

d. Choose Add / Edit notes for this topic.

e. Enter: The Trim function is good, but All-
trim is better. Add your initials and the date.

f. Click OK.

•A User Notes link is added to the top right 
of the page (aqua).

g. Click User Notes.

•Jumps to the notes at the bottom of the page (yellow above).

CUSTOM TOPICS You can create your own topic pages. They can be found as any other
AFTER you close and reopen the Documentation Viewer.

a. Click Notes on the toolbar (screen shot above).

b. Choose Add a custom topic.

c. Specify the name of the topic: MyCustomTopic.

HINT! Choose a naming convention for these pages in advance. For example, start
them all with “My.” It will help you locate them later. You could also add them
to the Favorites tab or create a List for them.

d. Enter your information in text or HTML format. (Click OK)

RETRIEVE Do the following to retrieve the page:

a. Close the Documenta-
tion Viewer and reopen.

b. Filter: Enter the topic 
name: MyCustomTopic.

•The page is found and 
identified as a User Topic 
(red circle and yellow high-
light).

EDIT There are two ways to edit custom topics. 
•Topic page: Click Add note (gold arrow above).
•Toolbar: Click Notes > Manage Notes > Edit Note (screen shot 

below).

DELETE After you create the custom topic, a new item is
added to the Notes menu.

a. Click Notes > Delete topic.

b. Confirm deletion.

NOTES DIRECTORY To identify and/or change the directory where the Notes are stored, go to:

a. Preferences > Table for user notes: Click to Define.
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b. Choose SQL or DBF.

c. Complete dialog as indicated.

•Be sure to read notes about sharing across the workspace and/or 
creating tables.

Printing topics
Printing is done to a PDF file which you can then print out if you like. You

can print a single page or combine multiple pages into a “book.”

SINGLE PAGE a. Select the page you want to print from the right pane.

b. Click Print on the toolbar.

•If only one page is open, printing will begin immediately.

•If more than one page is open:

c. Click Print > Print current topic.

•PDF document will be opened in Adobe 
Acrobat.

MULTIPLE PAGES Printing multiple pages will result in a PDF document with a Table of Con-
tents and Bookmarks.

a. Open the pages you want to print.

b. Click Print > Print selected topics (screen shot above).

c. Choose the topics individually or use the hyperlinks at the 
bottom of the dialog to do one of the following:

•Select All, Un-select All, Wildcard Select.

d. Click Wildcard Select to see how it works.

e. Click Select All. (Click OK)

f. Click OK.

•Documents are printed in alphabetical order.

•The PDF document is opened.
•Note it has been saved as an a5_temp file (top of 
window).

g. File > Save As: Rename and save in desired loca-
tion.

Updating the documentation
From time to time, the folks at Alpha update or add pages and remove out-

dated material, so you should refresh your local content periodically. There’s a
reminder for that.
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REFRESH ALL TOPICS Refreshing all the topics takes only a few moments. 

a. Click Refresh help topics on the toolbar.

•Alpha Anywhere checks the server for 
revisions and returns a notice of the action 
taken. In this case, our topics were all up to 
date.

b. Click OK.

•You are then notified that the DV will be closed and reopened.

c. Click OK.

REFRESH A SINGLE TOPIC You can refresh a single page, if you like.

a. Topic List: Select the page.

b. Right click > Refresh topic from server.

SETTING A REMINDER You can have Alpha Anywhere remind you to refresh topics when you open
the DV.

a. Preferences > Display reminder to refresh documentation every: 
Enter number of days.

•Default - 14 days.

Window style
You can have the window appear as MDI or Modeless. This is well illustrated

in Video #3. 
•MDI allows you to move from window to window. Recommended for 

use with single monitor. Default.
•Modeless means that you are “locked” in the window until it is dis-

missed. Good for users with dual monitors.

• The setting is located at:

a. Preferences > Window style.

Restoring open pages
You can specify whether or not you want Alpha Anywhere to restore the

most recently used tabs upon opening the DV. You can also set the maximum
number of tabs to restore.

• The setting is located at:

a. Preferences > Restore tabs on startup: Choose Yes or No.

b. Preferences > Maximum number of tabs to store: Enter number.

• Default = 20.

Sending feedback
There is a button at the bottom of each document that will open a window

where you can submit comments on the topic directly to Alpha Software.

a. Select the document, scroll to the bottom and click Send Feedback.
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b. Enter notes, your email, etc.

c. Click Send Feedback.

•A Notice is returned with an ID number.

d. Make note of the ID number for future reference. (Click OK)

NOTE This feature is not available if you add notes (page 458) to the topic page. 

Using the Video Finder

After all that work on the Documentation Viewer, this section is going to be a
piece of cake!

Alpha Anywhere has a wealth of videos, most of which are for web/mobile.
They are easy to follow and you will find them extremely helpful. Each is iden-
tified by Number, Category and Description. Some of the numbers have pre-
fixes, as M38 below. Others do not. Even though many created for earlier
versions, they are still applicable.

1. Open Alpha Anywhere and click Videos on the main toolbar.1

•Available at Web Projects Control Panel and Control Panel.

2. Enter a Filter.
•The Category list comes up, with the number for each listed at the left 

(in parenthesis).

Filtering
At this writing, only simple searches are available. There is no provision for

“and,” “or,” etc. That is on the Alpha “to do” list, however, so keep an eye out
for a Search Syntax hyperlink next to the filter box.

1. If you don’t see the Videos button, go to Help > Video Finder. The button is coming soon – promise!
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Refreshing
Just as with the DV, you will need to refresh the video content from time to

time. You can do it manually or add it to your preferences (see below).

Preferences
You can define the Window style and set an automatic update.

3. Click Preferences on the toolbar.

WINDOW STYLE There are two window style options, MDI and Modeless.

a. Choose MDI (default) or Modeless.

•MDI: This is the standard view (default). Recommended if you 
are using a single monitor. (See below for wide screen monitors.)

•Modeless: If you are using two or more monitors, you can drag 
the VF window to one of them and keep it open while you are 
working. This also works if you have a wide screen monitor and 
want to place the Alpha Anywhere workspace on one side and the 
Video Library on the other.

MODELESS WINDOW 
STYLE

If you choose the Modeless style, a Menu button will automatically be added
when the screen is too narrow to display both the categories and the video list.

• When the Menu button is clicked, the category list slides out on top of the 
video list (yellow below).
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CHAPTER 9. HEAVENLY HELP PLUS!
 Using the Video Finder
This latest version of the Video Finder was build using the UX List Control.
The menu style is called “Docked Panels” and we explain the feature in detail in
Volume 2 of this series.

AUTOMATIC UPDATE If the number of days since the last time the Video Library was updated is
more than this number of days, the Video Library will be updated automatically
when the Video Finder is loaded.

b. Automatically update Video Library every 5 days. (Default)

•Set to 0 to turn off automatic updates.

4. Click OK or Cancel to close the Preferences dialog.
•If you make a change and click OK, the Video Finder will be closed 

and reopened to make the change.

Can you believe that’s all there is to Video Finder? We’re done!

GO TO ALPHA VIDEO See how the Video Finder was developed with the List Control.

• Videos > Filter: Enter Video Finder. Choose:

•VF_V12-1. Finding Videos in the Video Library.
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