
 Chapter 2. 

Workspaces and Tables

Once upon a time…

Businesses stored their files in cabinets. If you are still in the land before time, we will show you
how to convert your paper to electronic power. If you are in the forefront of technology and looking
for a better way, Alpha Anywhere’s flexibility is just what you’ve been dreaming about.

Choose your file type – DBF or SQL. Alpha Anywhere is for non-programmers and experts alike.
Its Xbasic programming language puts developers on a quick, easy path to further customizing. Or let
the genies do the work in the background. The choice is yours.
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Image on reverse: Used under license from Shutterstock.com.
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Who needs this?
While this chapter does discuss DBF tables, it contains fundamental ele-

ments that apply to all users.

Creating a New Workspace

We stated above that Alpha Anywhere is more than just a workspace. As a
result, the term “workspace” is now used instead. In this exercise, we will create
a new DBF workspace and enter a table into it. If you have several projects, it
may be best for each to have its own workspace.

VERY IMPORTANT! Be sure to put each workspace in its own folder. Many files will be cre-
ated and you don’t want them mixed up with the Alpha Anywhere program
files.

1. Start Alpha Anywhere from the Start menu

or the program icon.

If you do not see the screen at left, click Top
Menu > Recent Workspaces.

There are 2 tabs on the opening screen:*

• News & Updates: This screen is actually a web page.† It reports new infor-
mation from Alpha Software and gives helpful links. If your software is out 

of date, a warning advises and provides a link to the latest patch download.‡ 
You can also access the download files from within Alpha Anywhere: From 
the Top Menu, choose Help > Download patches.

• Workspace & Tasks: Opens and creates workspaces; also opens a collection 
of Sample and Tutorial workspaces (see inset below).

*. This screen is sometimes referred to as the Welcome Screen.

†. As in many other instances, this screen is dynamic, meaning it may change from time to time depending on your most recent update. 

‡. Updating always follows the same procedure: 1. At the Alpha website, choose the appropriate file for your software edition. 2. 
Download. 3. Before running, close Alpha Anywhere—not always required, but a good practice. 4. Follow instructions.
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The first time you open Workspace and Tasks, you will probably see the screen at left
that asks you to choose the type of workspace you would like. This is just a starting
point and can be changed at any time.

Once Alpha Anywhere is opened, you can also move freely between the
desktop and web sides, so this choice is not critical.

Since we’re working on a desktop application, however, I suspect you can
guess what our choice will be.

2. Tab: Workspace & Tasks: Types of
Applications you want to build: Choose
Desktop. 

•There are several ways to create new 
workspaces. We will create a new, empty 
one and you can explore the other options 
on your own.

•Note the Sample and Tutorial Workspaces 
that have been included with Alpha Any-
where.

3. Choose Create a new, empty work-
space.

4. Click OK at the following screen.

5. At the Create New Workspace window, navigate to the c:\Alpha_MadeEasyDesktopBook\ folder.

6. Create and open a new folder* with the following name:

c:\Alpha_MadeEasyDesktopBook\MyNewDB.

7. File Name: Enter the name of the workspace.

AlphaAnywhereBasics

8. Click Save.

The workspace is created and
the Alpha Anywhere Con-
trol Panel appears.

Understanding Tables and Fields

PLEASE TAKE A MOMENT TO 
READ THIS

Tables are composed of 15 types of fields. 

*. Putting the workspace in its own folder is very important.
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• Character

• Numeric

• Date

• Logical

• Time

• ShortTime

• ExponentNumeric

• Memo

• Bitmap

• OLE

• Rich Text Memo

• JPeg Image

• Image File Reference

• HTML Memo 

• UUID 

CHARACTER The most common field type, it holds alphanumeric data. Character fields
may contain letters and numbers.

When you are planning to store numbers in a field, consider the following:

• Character fields can show leading 0’s. [For example, Zip Code= 
07760] Numeric fields can not.

• Character fields can have both letters and numbers [C 0556]. 
Numeric fields can not.

• Character fields can have other symbols: [Phone = (732) 842-3000] 
Numeric fields can not.

For some character fields, the width is arbitrary, such as first name, company,
city, etc. Others, such as phone numbers and zip codes are determined by the
complete number of characters they will hold. For example, in the next lesson,
we will use field rules to set up phone numbers to be viewed as (732) 842-3000
(14 characters) and zip code as 07760-0453 (10 characters).

NUMERIC Fields on which you might want to perform calculations. Numeric fields
accept only numbers and the decimal point.

• When planning the width of a numeric field, include the decimal 
point, decimal places and one extra space for a minus sign, even if 
you do not plan to enter negative numbers. For example, if the larg-
est number you plan to store in a field is 9999.99, make the field 
width 8 with 2 decimal places.

• In the Form and Report editors, you will be able to format numbers to 
display dollar signs ($500.00) and commas (400,000.00).You will be 
able to show fewer decimals on reports, forms, etc. than created in 
Structure Table, but not more. 



CHAPTER 2. WORKSPACES AND TABLES
Understanding Tables and Fields

14

• For example, a field structured at 4 decimals could read 400.9099 on 
a report. It could also be set to 2 decimals at the report level, in 

which case it would round to 400.91.* 

DATE This field type only accepts valid dates. It is aware of the calendar, including
leap years. Automatically set to a width of 8. See “Enter Date Field” on page 84
and “Creating a Rich Text object” on page 230.

LOGICAL Contains one character, which is used to represent a TRUE or FALSE value.

TIME Shows date and time. This field type only accepts valid time format. Auto-
matically set to a width of 17. See “Creating a Rich Text object” on page 230.

• 11/30/2005 12:00 00 pm 

SHORT TIME This field type only accepts valid time format. Automatically set to a width
of 9. See “Creating a Rich Text object” on page 230.

• 12:00 00 pm

EXPONENT NUMERIC A fixed precision decimal number.

MEMO A 10-character width is automatically created. In actual use, the field
expands. The only limit to the number of characters is available disk space. 

• Formatting of characters not available. (see Rich Text Memo below.)

BITMAP Stores bitmap (.BMP) pictures as data in the table.

OLE Used to link a document, such as a spreadsheet or graph, using the OLE
method. 

RICH TEXT MEMO This is the second type of memo field available. It, too, is automatically set to
a width of 10. It differs from the Memo Field in the following manner:

• Paragraph formatting is available.

• Character formatting, such as bold, underline, color, etc., is available. 

• Fields can be inserted.

JPEG IMAGE Stores JPEG (.jpg) pictures as data in the table. JPEG files are much smaller
than bitmaps. Bitmaps may also be stored in JPEG fields. When bitmaps are
stored here, they are automatically converted to JPEG files.

IMAGE FILE REFERENCE This field type is also called a “linked image field” because the image is not
stored directly in the workspace. Only the reference is stored. Since graphics
files can be quite large, using links can result in a significantly smaller work-
space.

HTML MEMO This is the third type of memo field available. It, too, is automatically set to a

width of 10. It allows access to the HTML† Editor where web pages can be cre-

ated and stored in the workspace, using either WYSIWYG‡ or HTML.

*.The ROUND function is also available to round decimals to a certain number in calculations. 
See Help > References > Functions & Methods > Mathematical Functions > Round(). We’ll 
talk lots more about functions as we work through the book.
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UUID This field returns a UUID (Universally Unique Identifier), similar to a GUID
(Globally Unique ID). It is intended for advanced SQL users. An example might

be {fj56co90-et23-r5i6-564w-rr45-rk34rbl5}.*

HINT! If you plan to move your workspace from one drive to another, it is a good
idea to set up Aliases in order to maintain links. (See “Understanding Aliases”
on page 424.)

In planning tables, keep the following in mind:

• The width set for a field governs the size of the table because space is 
reserved even if the field is empty or partially filled.

GO TO ALPHA HELP In this series of lessons, we will use the following field types: Character,
Numeric, Date, Logical, Memo, Rich Text Memo, JPEG Image and Image File
Reference and HTML Memo. To learn about the other types and more about
fields in general, see:
Documentation > Filter: Enter Creating a New Table.

• Help > Tutorials > User Guide Desktop > Working with Workspaces. See also 
links at bottom of page.

• Remember that the above references have been shortened a bit. 

• Help = Top Menu > Help > Open Help File. 

• For more information on using the help file, see “Videos in the book” on 
page xi.

Creating a new table.

1. On the Alpha Anywhere Control Panel, click the Tables/Sets tab.

2. Click the New button.

PLEASE TAKE A MOMENT TO 
READ THIS

There are several methods for creating a table.

• The first three, Design mode, Text mode and by Example are intended for 
Alpha Anywhere users.

• The next two, Passive-Link and Active-Link, are for remote workspace 

users.†

• Mapped Tables are discussed in “Understanding Mapped Tables” on 
page 119.

• There are two methods for importing data into tables:

• Import from SQL Workspace.

†. HTML: Hypertext Markup Language. This is the code for writing web pages. 

‡. WYSIWYG: What You See Is What You Get. Even the uninitiated can create web pages by entering text and/or pictures in the 
HTML Editor. The code is created in the background and can be seen at the Source tab.

*. Alpha Anywhere also has an easy-to-use feature that provides a unique ID for each table. (See “Defining Auto Increment fields” on 
page 80.)

†. Active- and Passive-Link tables are discussed in Alpha Anywhere and SQL by Susan Hussey Bush. Available at www.libertymanu-
als.com.
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• Import > Import Genie & Import Builder. Importing is discussed 
in Chapter 10.

•  A Set is a combination of tables and is discussed in Chapter 6.

•  Create using Genie has some interesting pre-designed tables for certain 
pursuits such as Artists, Home Inventory, Invoice Header and Line Items. 
You may want to look at the selection to see if it could be useful to you.

•  Click the Preview button to see the fields in the table.

We will use the classic method, Design mode because it best illustrates the
principles of table design.

GO TO ALPHA HELP Once table design is understood, you may wish to experiment with the other
styles. To see them illustrated, go to:

Documentation > Filter: Enter Create a New Table from Sample Data.

Documentation > Filter: Enter Create a New Table by Example.

3. Choose New Table (Design mode) from the drop
down list.

• Be sure the Tables/Sets tab is active.

• The Create Table window appears:

• This is where fields are created. 

4. Click in the Type field and open the selection box
to see the choices.

HINT! Since the field types all begin with a different letter, pressing the first letter
will quickly insert the type. For example, pressing C will select Character.

WINDOWS HINT! For quick keyboard access to drop down lists such as the list of field types,
use ALT + DOWN ARROW. This will work in all Windows applications.

• Next, we will set up the table.

5. Click in the first entry box of the Name column.

6. Enter the fields as follows:

• Press TAB to navigate between cells.

NOTE Notice that Alpha Anywhere replaces the spaces in field names with under-
scores. That is, First Name becomes First_Name. The case is also set by the
program, so first name will also become First_Name after you save the table.

The last column, Indexed?, is discussed on page 416. No entry is necessary at
this time.

Name Field Type Width Decimal

Client ID Character 5 0

Enter Date Date 8 0

First Name Character 12 0

Middle Initial Character 2 0

Last Name Character 20 0
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7. Save the table:

• There are three ways to save in Alpha Anywhere. All are common Windows 
commands:

a. Choose File > Save.

b. Press CTRL + S.

c. Click the Save button at the upper left of the screen.

BASIC SKILL: *CTRL + S We prefer CTRL + S because it’s faster and will use this method in our les-
son instructions. You may prefer to use a different method.

•The Specify Table Name 
window opens.
The left window lists the tables
in the current workspace. This
will help you in locating a
unique name for your new
table. Since this is the first

table in the new workspace, the left window is empty.

• By default, the table will be saved in the same folder as the work-
space.

8. Type in the file name: Clients. (Click OK)

• After saving, you are returned to the Restructure Table window.

9. Click either the X in the upper right of the Create Table window or the
Close button on the top menu to exit.

• The newly created table appears in the list.

•This table has only 3 types of fields: Charac-
ter, Date and Memo. 

Company Character 35 0

Address 1 Character 25 0

Address 2 Character 25 0

City Character 25 0

State Character 2 0

Zip Code Character 10 0

Phone Character 14 0

Fax Character 14 0

E-mail Character 30 0

Website Character 40 0

Notes Memo 10 0

*. Basic Skills are preferred methods and will be used throughout this book.
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• To see other types of fields and further explore the Control Panel, we will close this workspace and open 
the ABC_Seminars workspace, the basis for most of the lessons in this book.

Closing the workspace
You can close the workspace in several ways. The first two of the following

methods also close Alpha Anywhere. The third keeps Alpha Anywhere open,
but closes the current workspace and opens a different one.

• Click the EXIT button when you are at the Alpha Anywhere Control 
Panel.

• Click the X in the upper right corner of the Alpha Anywhere window.

• Switch to another workspace as we will do in the next exercise.

Opening multiple workspaces
You can have more than one Alpha Anywhere workspace open at one time

by opening another instance at the Windows Start Menu or by clicking on the
program icon on the desktop.

Understanding the Alpha Anywhere Control 
Panel

PLEASE TAKE A MOMENT TO 
READ THIS

The Alpha Anywhere Control Panel is its main menu and the heart of Alpha
Anywhere design. It lists the Tables, Sets, Forms, Browses, Reports, Letters,

Labels,* Operations and Codes that have been created for the workspace.†

• This exercise continues from the previous one. The AlphaAnywhereBasics 
workspace is still open. We will now switch to another Alpha Anywhere 
workspace and the first will close automatically.

• You can also open this workspace directly from the Alpha Anywhere open-
ing screen.

1. Top Menu: Choose File > Open Workspace.

2. Navigate to c:\Alpha_MadeEasyDesktopBook\ABC_DesktopLes-
sons\
ABC Seminars (alpha5 Document).

3. Click Open.

• The workspace opens at the ABC Seminars menu.

*. Envelopes may also be made at the Labels tab.

†. Depending on the version of Alpha Anywhere that you are using, additional tab(s) may be shown. This manual covers only the tabs 
mentioned above. All tabs are covered in this book


