
 Chapter 8.

Customize Your App!

All tricked out …

That’s what people will think about your application when you add 
custom menus, toolbars, and bubble help. And - don’t make users wonder 
how long a script will take – show them.
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What’s in this chapter
Alpha Five gives you lots of ways to make your application unique. Each also adds

functionality for the end user by making the application easier to use and the actions
clearer.

ALPHA FIVE STARTUP At a minimum, you should customize the startup by creating your own shortcut that
opens Alpha Five and defining a start-up form.

•“Customizing the Alpha Five Startup” on page 209.

CUSTOM MENUS AND 
TOOLBARS

Right click and View (Top) menus can be designed to add functionality. Modify the
default menus or create entirely new ones. The choice is yours and we show you how.

•“Understanding Custom Menus” on page 213.

•“Creating a Custom Right Click Menu for a Form” on page 215.

•“Creating a Custom Right Click Menu for Fields” on page 219.

•“Creating a Custom View (Top) Menu” on page 223.

•“Creating a Custom Toolbar” on page 225.

WAIT DIALOGS Have a long script that takes a while to complete? Let the end user know its progress
with a “Wait Dialog.”

•“Showing the Progress of a Script” on page 227.

BUBBLE HELP It’s true that Bubble Help is often just a simple note. But, did you know that it can
also contain images and save space on a form? This exercise will open you to lots of
new ideas.

•“Showing More with Bubble Help” on page 232.

Customizing the Alpha Five Startup

• Reprinted from Alpha Five Made Easy, The Basics and More by Susan Hussey 
Bush. If you have already done this exercise, you can skip to See “Understanding 
Custom Menus” on page 213.

There are several ways to customize the Alpha Five startup. You can change the
desktop shortcut so that it has a custom name and either Alpha Five logo or your own.
You can define the way the program appears when it is open by naming the title bar and/
or using a custom icon for the Start bar. We will show how to create a desktop shortcut
and title bar and give you the parameters for creating your own icon. There are addi-
tional features, such as a custom “Splash Screen” that you can discover on your own.

• Always create shortcuts from within Alpha Five.*

Creating a Desktop Shortcut
This custom desktop shortcut will open the database without going through the ini-

tial file selection process.

*. Shortcuts created at Windows sometimes give an error message.
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1. Open Alpha Five to the ABC Seminars data-
base.

2. At the Alpha Five Control Panel, choose Tools >
Create Shortcut

 Dialog: Create Shortcut Genie

3. Tab: General > Shortcut Name: ABC. 

4. Desktop shortcut: On desktop.

At this point, your new shortcut will have the Alpha
Five logo and be named ABC as above If you click
OK, you will get the message that the shortcut has
been created. Before we do that, however, we will
name the title and start bars.

Naming the Title and Start bars
• This exercise continues from the previous one. You should be at the Tools > Create 

Shortcut dialog.

The title of the main Alpha Five window is at the very top of the program, above the
top menu. The Start bar is the Windows system bar at the bottom of the screen where
open programs are shown. In Windows XP and earlier, the Start bar has both a logo and
text. In Windows 7, it is just an icon.

5. Tab: Appearance: Click Use Custom Title and enter
ABC Seminars in the box.

6. Click OK.

•You are notified the shortcut has been created.

7. Close Alpha Five.

8. Go to the desktop and double click on the new shortcut.

• Alpha Five opens directly at ABC Seminars. 

•The title bar shows the Alpha Five logo and ABC Seminars text.

•The Start bar shows (1) Windows XP A5 logo plus ABC Seminars text or (2) 
Windows7: A5 logo.

Adding a Custom Icon
• This exercise continues from the previous one. ABC Seminars should be open.

A custom icon can be defined for any Windows version, but is especially useful for
Windows 7 because the Start bar uses only icons to identify open programs. It replaces
the Alpha Five logo as at left: (1) Shortcut, (2) Start Bar, (3) Title bar.
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A. Create an .ico file

•You will first need an image that will serve as a logo. It 
takes a bit of experimenting to get a good logo because the 
size is different for each purpose. For the start bar, rectangu-
lar is best. We used 70 x 80 pixels for our sample.

•Using a photo or image enhancement program, save it as an 

.ico file. (We used Snagit.*) 

B.  Add the custom icon to Alpha Five startup

We have included an icon so you can test the results of the exercise.

9. Windows Desktop: Delete the icon created in the previous exercises.

•While you can have more than one desktop shortcut for an application, it is 
cleaner to the delete previous one and start over when creating a new one.

10. At the Alpha Five Control Panel, click Top Menu > Tools > Create
Shortcut.

11. General tab: Enter ABC.

12. Appearance tab: Enter as follows:

•Title of Main Alpha Five Window> Use custom title: Enter ABC 
Seminars.

•Icon > Custom icon: Browse to:
 c:\A5_MadeEasyDesktopBook\Samples\ABC.ico.

13. Click OK.

14. Close Alpha Five.

15. Go to the Desktop and double click on the new shortcut.

•This time the new icon replaces the Alpha Five logo.

NOTE We found that we could have only one custom icon per copy of Alpha Five. In our
office we run a couple of Alpha Five databases, so we had to choose which one would
have a custom icon.

SPLASH SCREEN You can also define a custom splash screen (Appearance tab). This is the screen that
appears while Alpha Five is loading.

EDIT STARTUP SETTINGS You cannot edit the settings directly, so just delete the shortcut that you don’t want
and create a new one in its place.

Creating a Startup Form
A certain form can be designated to start up each time the user opens the database.

Any form may be selected. 

*. We use Snagit for our screen shots and recommend it highly. It also has photo enhancement features, one of which being the ability 
to create icon files. www.techsmith.com.
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• In many cases, this will be a Main Menu. 

• In others it could be a form with a password protected button so that unauthorized 
users cannot open the database.

Startup forms can be elaborate or very basic. In the exercises, we have seen two
examples. The first is the ABC Seminars menu that opens when you do the exercises.
The second is the one for the Alpha Sports database that comes with Alpha Five
(page 246). The former shows the control panel on startup, the latter hides it.

First, we will define the start-up form and then we will show how to hide the Control
Panel.

16. Create a Startup Form based on the Menu table.
(We used the main menu.)

•Any form may be the Startup Form.

17. Go to the Alpha Five Control Panel. (Any Tab)

18. Choose File > Database Properties...

19. Tab: Startup.

20. Check When this Database is opened, open a startup
form.

21. Choose the form you want to run when the program
is loaded. (Click OK)

22. Close and reopen the database.

• The Startup Form loads in front of the Control Panel.

• To hide the control panel, see below.

ADVANCED USERS • There is an additional setting at View > Settings > System > Preferences > Startup 
Form > Display Startup Form. See the note on the dialog about debugging.

GO TO A5 HELP For a couple examples, see:

• Help > Wiki Search Assistant: Enter Startup. Choose Creating and Assign-
ing a Startup Form.

Hiding the Control Panel
In certain circumstances, it may be desirable to keep the end user from seeing the

control panel. The Alpha Sports database* contains an example of a Startup Form that
hides it.

VERY IMPORTANT! You must have a way to get the control panel back! Before proceeding with this
exercise, have a plan for retrieving it. Usually a button is placed on the Startup Form for
this purpose, as in the above example.

23. Begin at Design mode for the Menu form or whatever form you are
auto-loading as the Startup Form. (See “Creating a Startup Form” on
page 211.)

24. Toolbox: Button object. Draw a button with the following settings.

*. For the location of this database and instructions on accessing the control panel, see “Open the Alpha Sports database” on page 246.
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a. Label: Show Control Panel; choose Use Action Scripting. (Click 
Next)

b. Click Add New Action.

c. Category: Control Panel; Action: Control Panel Show. (Click OK) 
(Click Finish)

25. Save and Close the Code Editor.

26. Save the form; return to Form View.

• Next, we will hide the Control Panel.

27. At the Control Panel, choose File > Database Properties.

28. Check Hide the Control Panel. (Click OK twice)

•A warning message comes up with instructions on getting the Control Panel 
back. These instructions have been included here for future reference — see 
“What to do if you’re locked out” below.

Now, whenever the form is run, the control panel will not be accessible to the user
unless the button is clicked.

HINT! You can get creative with this button — maybe by making a hot spot (like a flat but-
ton) that you put at the lower right of the form without a label – perhaps with a graphic
instead. That way only authorized persons will know how to open the Control Panel.

WHAT TO DO IF YOU’RE 
LOCKED OUT

If you hide the Control Panel and do not have a button to get it back, you will be
locked out of the database. Here are the steps to unlock the database:

a. Open another database that does not have a Startup Form (create a 
new one if necessary).

b. Choose View > Settings > Preferences > Start-up Form.

c. Set Display Start-up Form to No.

d. Open the database out of which you are locked.

e. Choose File > Database Properties; Uncheck Hide Control Panel.

Understanding Custom Menus

Alpha Five permits you to change the existing menus, create entirely new ones or
even remove them completely. The advantage is that you can present the end user with
only the options that are relevant to the particular situation. In the example at left, the
Print Current Record option has been added to a right click menu.

The Top Menu seen at View mode can also be customized. The Alpha Sports data-
base (page 246) has a good example of this. The Top Menu and Toolbar for the start-up
form have been changed from the default to much shortened versions.
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•Forms: 

•Right click menus: Background at View, Query by Form and Find by 
Form modes as well as Fields.

•View menu (top menu that normally begins with File as above) at View, 
Query by Form and Find by Form modes.

•Browses:

•Right click menu: Fields; View (top) menu.

•Report Print Preview:

•View (top) menu.

Custom menus are saved under individual names at the Code tab. Design is a 2-step
process: 

•Code tab: Create the custom menu.

•Form, Browse or Report Print Preview: Apply the menu to the layout or the 
field.

In all cases, the default menus remain unchanged. The custom menus are applied to
each individual form or report. This means you can experiment at will without doing
any harm!

The following exercises will show how to do the following:

RIGHT-CLICK MENUS • Create a new menu for the form background by modifying the default (page 215).

• Create a new menu for a field starting with a blank menu (page 219).

VIEW MENU • Create a new menu for a report in Print Preview mode (page 223).

Once the basic principles are understood, you will be able to apply them to the
other situations.

1. Alpha Five Control Panel: Tab: Code.

2. Click New, choose Menu.
 Dialog: New Menu

Understanding the menu type
For your convenience, Alpha Five has provided the default menus for each type of
menu. You can start from scratch with a blank menu or you can modify the default
menus. 

3. Drill down (click the +) for each section to see the full selection of
default menus.

STARTING POINT
It is important to remember that a menu is a menu, regardless of whether a blank
menu or one of the defaults is selected. In effect, the dialog is asking which style of
menu you would like to use as a starting point for your new one. It’s where and
how you apply it that determines its use.


