Chapter 5.

Reports, Letters and Labels

Alpha Five has awesome reporting capabilities.
The power of a database is the multitude of ways the data can be viewed. The same information that confirms a sale can show a complete report of purchases by all customers.

CHAPTER 5. REPORTS, LETTERS AND LABELS

Notes:
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Preparation for the Lesson.
Open Alpha Five and navigate to the following file:
•c:\A5_Ver9Book\ABC_V9_Lessons\ABC Seminars.adb*
•
SPECIAL NOTES

Click on the Control Panel tab in the Window Bar at the bottom of the screen to bring the Control Panel to the front.

As fields are added to the form, the Summary Genie may pop–up. Accept the default
settings and click Finish.
These techniques my be applied to any report. To do so, open the report in design
mode to begin the segment.
These exercises are designed to be done in book sequence. If you do the Operations
section before this Reports section, the report may not match the steps in the book
because, when removing duplicate names, some client names may have been deleted.
To work around this problem, reinstall the data from the companion disk. It will overwrite any changes you have made.
Because this is a long chapter, it has been broken into a series of exercises. The quill
and inkwell mark the beginning and end of each exercise.

LOOKING AHEAD!†

The following reports may be previewed at the Alpha Five Control Panel Reports
tab. There are also buttons for some of the reports on the Clients form.
•Quick Report: FirstReportDemo
•Custom Reports:
•Registrations
•Receipt: To Print Preview, enter any ID from 00001 – 00007. (Button on
ClientInfo form)
•Schedule: To Print Preview, enter 00001
•Sub-Report: RegistrationsGenieDemo
•Letters: Confirmation Letter

Learning Report basics
Alpha Five presents a quick and easy way to get started with reports. We will first
design a report using the genie and then will update the report with some custom design.
FINISHED REPORT

Open the RegistrationsGenieDemo report to see a completed report for this segment.

Quick Reports mean a quick start
First, we will make a Quick Report.
*. Depending on how Alpha Five is opened, the file extension .adb may not appear. (For instructions on opening an existing database,
see “Using Alpha Five with a remote database” on page xi.)
†. For experienced or returning users. May be helpful to beginners who want to see the results of the exercise.
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1. Alpha Five Control Panel Tab: Reports.
2. Click the New button.
3. Data Source: registration_rept.set
4. Method: Choose Use Quick Report. (Click OK)
•The Quick Report definition dialog box opens.

5. Set the following parameters:
•Title: MyRegistrations.
•Style: Groups with totals.

6. Click the Fields button (should be default).
7. Select fields: Table: Choose Registration. Double click or drag the following fields to add them to the Fields box on the right side:
•Registration ID.
•Seminar ID.
•Registration Date.
•Paid Date.
•No Persons.
•Rate.
•Amt Pd.
HINT!

To remove a field from the Fields box, drag it off to the right, out of the box. It
should be removed from the list.

8. Table: Choose Clients. Double click the following field to add it to the
Fields box:
•Last Name.
REORDERING THE FIELDS
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• The fields appear on the report in the order listed in the Fields box. We will change
the order of the fields so they will be more logical for this report.
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9. Fields: Click Seminar ID, drag it up to the top of the list.
HINT!

If you have trouble getting the field to the top, move it to 2nd place. Then move the
top field below it—like a Rubix cube!

10. Drag Clients->Last Name to the 3rd position.
11. Click the Group button.
•The entry box on the right changes to Groups.

12. Double click Seminar ID to place it in the Groups box.
13. Click the Order button.
14. Double Click Clients->Last Name to move it to the Sort fields box.
15. Click the Summary button.
•The genie has filled in the fields—all numeric—that are eligible for a summary operation.

16. Click the Options button.
17. Click the checkboxes as follows:
•Fields: Bold.
•Page: Page Number, Day/Date, Center Title.

18. Click OK.
•The Report Editor appears. We will explain in detail each of the sections, but
first let’s make one quick change and then take a look at the report.

19. Right click on the large title in the report, MyRegistrations.
20. Choose Properties.
•Properties are changed here in the same manner as on forms.

21. Tab: Font; Color: Red. (Click OK)
22. CTRL + S to save.
•Save as MyFirstReport. (Click OK)
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23.

Print Preview the Report.
•Click the Preview button on the Reports Toolbar.
•Or choose File > Print Preview.

Understanding the Print Preview tabs
When you go to Print Preview from the Report Editor, an additional tab is opened in
the Window Bar below the report.
•If the tabs are not showing, choose View > Window Bar from the Top Menu
to open that section of your screen.

These tabs allow you to move quickly between Print and Print Preview. There are
certain notations, however.
•If you change the report, and then click the Print Preview TAB, the change
will not show.
•To show the change, click Exit Preview
Toolbar and reclick the Print Preview
Toolbar.

on the Print Preview
Button on the Report Editor

•If you did not save the report before clicking the Print Preview TAB, an asterisk will appear on to the Report Editor tab.*

•In order to save the report, you need to first click

Exit Preview

on the Toolbar and then save the report. When you reopen
Print Preview, the asterisk will be gone, indicating a saved and therefore current
design.

Understanding the Print Preview Toolbar
The Print Preview Toolbar gives a wide range of options for saving the individual
reports. For example, many companies are requesting that invoices be E-mailed. You
can save the report in one of four formats common to most computer systems and Email the report with the click of a single button.

IMPORTANT NOTE

As you preview this report, you will notice there is overflow onto a 2nd page. Don’t
worry about that now. We will fix it later.

*. This asterisk appears only at Print Preview. Its purpose is to note that a certain part of the Print Preview view no longer accurately
represents the entire report editor design. There may be other parts that you want to examine, however.
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VIEWING PAGES

The first group of buttons are for viewing certain pages in the report.
•First page.
•Previous page.
•Go to page <number> (Enter the number of the page to which you want to
go.)
•Next page.
•Last page.

PRINTING THE REPORT

The next group is for printing the report.
•Print.
•Print Setup.

VIEWING OPTIONS

The next group gives options for viewing the report on screen.
•Zoom.
There are two zoom settings, in and out.
You may also zoom by moving the cursor onto the report. It
changes to a magnifying glass. Click on the report to zoom in
or out.
•Two pages.
Shows 2 pages on the screen at one time. Zoom must be set
to lesser magnification so there is room on the screen for both
pages.
•Color.
Toggles areas with color off/on.

24. Click Color.
•The red Registrations title is changed to black.*

25. Click Color again.
•The Registrations title is set back to red.
RETURNING TO DESIGN
MODE

The next button returns to Report Design Mode.
•

SAVING REPORTS AS PDF,
HTML, RICH AND PLAIN
TEXT FILES

Exit Preview

The next two buttons have multiple choices. The first forms the report in a different
format where it can then be saved from that program. The second forms the report in the
selected format and opens a Send Email form, with the report attached. The major
advantage is that reports can be viewed by users who do not have Alpha Five installed
on their computers.
In addition to these formats, reports may be saved and printed within Alpha Five
itself.

26. Click the drop down arrow adjacent to the button next to Exit Preview.

*. At this writing, the text is actually disappearing from view. It does print properly, however. We have reported this to Alpha and,
hopefully, it will be fixed by the time you read this.
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•When you hover over the down arrow, bubble help reads: Select format for
saving report.
•There are 5 file types to which you can save and/or send the report.

NOTE

Our purpose at this time is to give an overview of the features available. Instructions
for enhancing these formats is detailed in “Enhancing PDF, HTML & Rich Text report
formats” on page 239.
• The icon on the button is for the last format used.

•

Adobe Acrobat PDF. Most users have Adobe Acrobat Reader on their
computers. It is also available as a free download at www.adobe.com.

•

Dynamic HTML File. Report will open in Microsoft Internet Explorer.

•

Rich Text File. This can be read and edited by users of Microsoft Word
and Corel WordPerfect.

•

Plain Text File. Removes all formatting. Can be read by any computer.

Excel File: Report will open in Microsoft Excel, as a spreadsheet.

•
SELECTION OVERVIEW

• To use or change formats:
a. Click

the current button or its drop down arrow.

b. Choose

the desired format.

c. If

you like, you can preview at the format options now, but we will examine them in detail at “Enhancing PDF, HTML & Rich Text report formats”
on page 239.

•The report will be formed in the chosen format.
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•That format will remain the default. In other words, if you format a report as
a Rich Text file, the

icon will appear on the Toolbar.

•It can, of course, be changed to a different format at any time.
NOTE

If you do not save the report prior to going to Print Preview, you will get an error
message advising you to return to design mode and save the record.

27. Choose Adobe Acrobat PDF File.*
28. File name: Accept the default.
• C:\A5_Ver9Book\ABC_V9_Lessons\MyFirstReport.pdf

29. Open file with associated application? Check (Yes)
30. Click OK.
•The program may ask for permission to overwrite an existing field. (Yes)
•If it is unable to find a PDF driver, Alpha Five will ask for permission to try
to install it. (Yes)
•If the PDF driver is installed correctly, the report appears on the screen.

31. Close Acrobat.
SENDING EMAIL
ATTACHMENTS†

The process for sending email attachments is essentially the same as above.
a. Click

the current button or its drop down arrow.

b. Choose the desired format from the Send As dialog.
A third step is necessary, though. In order to actually send an email, you will need to
tell Alpha Five which email client to use. For the purposes of this exercise, we will
choose Default e-mail client to use your existing e-mail client, such as Outlook or Outlook Express. E-mailing with Alpha Five is discussed in Chapter 13 beginning on page
413.

32. Click the Send a report via email button.
33. Choose Adobe Acrobat PDF File format.

*. This choice requires that Adobe Acrobat Reader be installed on your computer. You may get a free download at www.adobe.com.
You may also choose another format if you prefer.
†. If your computer is new and/or you have not set up an email account, you may be directed to go to the “Mail Icon on the Control
Panel.” This means the WINDOWS CONTROL PANEL, not the Alpha Five Control Panel. Open the Windows Control Panel and
click on Mail to set up the account.
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34. Click the Options button.

35. Choose Default e-mail client. (Click OK)
36. Click OK and then Click Send.
•The report is formed and the send email window opens with the report
attached.

37. Close the email window—or send yourself a test email! And while
you’re at it, send me a copy! I’ll be sure to email you back a congratulatory note for getting this far!*
MORE WAYS TO CLASS UP
YOUR REPORTS

• Note that these file types support color as well as black and white type. That means
you can put your color logo on a report and email it to your customer.
• You can also post these files on your web site for viewing. The PDF format works
very well for this. Just put the link on your web page and store the actual file on the
server.
• When composing a report to be transferred to Excel, you will want to take that format into consideration. This report, for example, would require a fair amount of
modifying in Excel, because of the location of its total fields.

ALPHA FIVE CONTROL PANEL

The final button on the toolbar takes you to the Alpha Five Control Panel.

38.

If possible, print a copy of the report, now. You will find the
print–out handy to use as a reference for the following exercises.

*. My email address is susan@LibertyManuals.com.
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•Click the Print button on the Reports Toolbar.
•Or choose File > Print or CTRL + P.

39. Click Exit Preview.
•You are returned to Design mode.
If, for any reason, you are no longer in Design mode, do the following:
•Alpha Five Control Panel Tab: Reports
•Right click > Design: MyFirstReport (or RegistrationsGenie).

40. Maximize the Report Editor to make it as large as possible on the
screen.

PLEASE TAKE A MOMENT TO
READ THIS

Understanding the Report Editor*
• Toolbox: The Report Editor Toolbox contains fewer tools than that of the Form
Editor Toolbox, however, the use for each tool is the same. The Sub-Form button is
replaced with the Sub–Report control
•If you cannot see the full report editor, we recommend you make the Toolbox
and DragDrop List as narrow as possible.
• DragDrop List: Same for both the Report and Form Editors.†
• Report Toolbar: Same as the Forms Toolbar,‡ plus one new button, Select
Records.
• Reports Top Menu: differs from the Forms Top Menu** as follows:
•View: There are 3 new options that toggle on/off various elements of the
report. (See “Viewing sections” on page 195.)
•Report:
a. Select

Records. Applies filters. (See “Filtering and Ordering reports” on
page 227.)

*. This segment covers the basic elements of reports. For more information on the features available in reports, see A5 Help > User
Guide > Reports.
†. See “Using the DragDrop List” on page 95.
‡. See “Understanding the Forms Toolbar” on page 80.
**.See “Understanding the Top Menu” on page 76.
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