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Welcome to

Alpha Five Made Easy
The Basics and More for Version 10

Special Alpha Software Blog Edition

Installment No. 1

Introduction, Table of Contents, Databases and Tables*

Getting Started

This book is designed to be used in conjunction with databases that may be downloaded free of 
charge at http://www.libertymanuals.com/fix-it-here.html. The databases need be installed only once 
for the entire series. If you reinstall them, any work you have done previously will be overwritten.

Please be sure to read the Introduction, including “Getting Started” on page x, for instructions on 
installing the databases and other important information.

REFERENCES:
The copy herein is an actual representation of the book, which has been divided into sections for insertion

into this special edition. Throughout, there are references to other pages in the book. Some are “backwards”
references and are included in this reprint. Others send the reader to sections not yet covered and will not be
available until that section is reprinted.

All references are to the book page, not the Acrobat file page. The book page number is located at the bot-
tom of each page.

PERMISSIONS:

•This book is copyrighted, therefore you are not permitted to make any changes to the document.

•You are permitted to print the pages.

EDITIONS

This book is available in Hard Copy and Electronic Download Edition. Both are 
available at www.libertymanuals.com.

•The Hard Copy includes a free copy of the Electronic Download Edition so you can get started right 
away.

•The Electronic Download Edition contains Bookmarks for each section in each chapter and the Acrobat 
pages have been syncronized with the book pages.

*. Reprinted with permission.
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Alpha Five’s Functions allow the develop-
ment of database applications without program-
ming. In this handbook, they are explained
simply, in layman’s terms. This manual was
born of the author’s many years of frustration
while searching for the right function for the
job. Character, dabte, numeric, summary or fil-
ter—you’ll find and use them easily in this logi-
cally designed manual.

Available at www.LibertyManuals.com or call 1-732-842-3000

Expand your Alpha Five applications with the 

Alpha Five Functions Handbook, 
Functions and Expressions Made Easy

Alpha Five Web Applications Made Easy, 
The Basics and More for Version 10.5

Make the most of your software — your copy of
Alpha Five Version 10 comes with the ability to
design Web Applications. And this is the book that
will show you how to create your own.

Alpha Five: Xbasic for Everyone
by Dr. Peter Wayne

Learn Xbasic, Alpha Five’s programming language. 
Hard copies now available at 
www.LibertyManuals.com.
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Frances M. Peake, professional database developer, has this to say about 
Alpha Five Made Easy…

Susan Bush and I met at the Alpha Five
Developer’s Conference in December of 2000. I
was the professional developer. Susan used
Alpha Five in her business. After a short conver-
sation with Susan, I realized that she was much
more than an end-user. She has made a study of
Alpha Five over the years, pushing the product
to its limits to serve her business needs. 

Shortly after the conference, Susan came to
our South Florida Database User Group meeting.
She offered to give a presentation on a multi-step
import procedure she had devised in Alpha Five.
She impressed the group with detailed handouts
and screen shots. Then she hosted the next few
meetings while I was out of town. 

When I returned to the User Group meet-
ings, Susan pitched the idea of doing a seminar

to help Alpha Four* users make the transition to
Alpha Five thus our joint ventures, “Get Outta
DOS” and then “Get into Alpha Five!” seminars
were born. We agreed that, with all the prepara-
tion it would require, the seminars would not be
big money makers. So I asked, “What would you
want to get out of it?” She stated very emphati-
cally, “I want to do an Alpha Five book.” I can’t
remember whether I said this out loud, but my
first thought was “Are you out of your mind?”
But I knew it was true, Susan was going to write
her Alpha Five book.

The book that you hold in your hands is not
simply the product of Susan’s experience as an
advanced-level Alpha Five user. It is a product
of her vision and seemingly boundless energy
and enthusiasm. It is also a product of many,
many hours of research, writing, editing and
above all, attention to detail. 

Like so many of us in the Alpha Five com-
munity, Susan saw a need for additional training
and support materials for Alpha Five. Any of us
who have ever contemplated actually writing
such a book and imagined ourselves as the
author of, “Step 1. Right-click the mouse…Step
2. Choose Properties…” can only begin to
appreciate what Susan has accomplished here. 

This book can be used as both a tutorial
and reference manual. Susan has achieved a
healthy and practical balance between tutorial
and reference by offering short, compartmental-
ized exercises. The book and disk that accompa-
nies it are designed so that you can start at any
chapter. For example, if you want to jump right
into designing forms, you will not be lost if you
have not followed the lessons from Chapter 1.
You will find that every chapter is chock-full of
valuable information for Alpha Five users of all
levels.

The value of Susan’s experience using
Alpha Five in a real-world business environment
cannot be overstated. It is evident throughout the
book in the plain-English explanations of each
Alpha Five feature and in the examples she uses.
You will appreciate the generous use of screen
shots to guide you through the exercises. Best of
all are the tips and hints she provides to help
shorten the learning curve so that you can get the
most out of Alpha Five.

On behalf of Alpha Five users and enthusi-
asts everywhere, thank you Susan, for writing
this book!

— Frances M. Peake,† Co-owner, Proctor & Peake, Inc.
www.proctorandpeake.com

*. Alpha Four is a relational database program developed by Alpha Software, Inc. It uses the MS DOS platform.

†. Frances Peake is the author of Alpha Four to Alpha Five, The Transition, soon to be available at www.proctorandpeake.com and 
www.libertymanuals.com



About the author

 From her first computer experience
in 1984 - a used Apple I presented by her father
after he upgraded to an Apple II - Susan Hussey
Bush has been hooked on this amazing (and
sometimes frustrating) tool of the modern world.
The 1985 purchase of the state of the art IBM
XT with an astounding 10 mg hard drive opened
the door to database development. That first flat
database, Nutshell, showed her that one did not
have to be a programmer to develop applica-
tions. Later, she began the search for a relational
database that did not require programming skills.
Alpha Four, a DOS product, met those require-
ments. When Alpha Five was released, she
moved to the Windows version. After expending
considerable effort learning the program and
designing on her laptop, it was stolen. The only
copy of the database was gone and a serious set-
back resulted. The good news is that by the time
she started over, Alpha Five version 3, with sig-

nificant improvements over the earlier versions,
had been released.

The development of a database for her gov-
ernment bidding company, Liberty Food Mar-
keters Co., then began in earnest—this time with
backups! Today, that application contains more
than 60 tables and 75 sets. As a non-program-
mer, Susan has set up 100 saved operations to
import, reformat and export data. She has since
sold the business to her son, Dave, who contin-
ues to use Alpha Five to stay current with the
demands of government bidding and to offer
customers outstanding service.

Susan has a Bachelor of Fine Arts in Archi-
tectural Design. She brings that training to her
database design, focusing on well organized,
attractive forms and reports. Alpha Five allows
her to create database applications reflecting her
belief that software should be user-friendly. She
is excited about adding Version 10 features to
her databases.

She lives with her husband, Richard, in Flat
Rock, North Carolina. August, 2009 was a diffi-
cult month because Susan lost two siblings, who
died of unrelated illnesses.

Happiness comes in the form of Susan and
Richard’s blended family of seven children and
nine grandchildren, who are spread across the
country. Mike, Liz and Walter Hussey live in the
Florida Keys. JR Hussey and his wife, Carin
Young, live in Mill Valley, CA. In Rumson, New
Jersey, Susan’s hometown, Dave Hussey keeps
busy with Liberty Food Marketers Co. Rick
Bush’s daughters, Taylor, Jordan and Lindsey
live in Pea Ridge, Arkansas. He and his oldest
daughter, Hailey, live in Neosho, MO, where
Richard grew up. Ross and Mariola Bush and
daughter, Clara, live in Rolla, Missouri where
Mariola is a Civil Engineer and Ross is an attor-
ney. Residing in Fort Smith, Arkansas are Missy,
her husband, Jeff Brown and son Jake. Kathleen
and Sands Orris and their sons, William and Fos-
ter make their home in Cumming, Georgia.



This book is dedicated to my husband, Richard Bush ,
and my sister and brother, 

Cynthia Maria Fowler and John Alden Rathbun

Left: Cindy, Cathy and Robert with our 
parents, Walter and Libby Rathbun.

Cynthia Maria Fowler 1939–2009

Right: Robert all grown up!

Elizabeth, Cathy, Cindy and
Chuck welcome in 2004.

Cindy’s life centered around her three children, Elizabeth, Cathy and Chuck, 
her grandson, Robert, and her church.

John Alden Rathbun 1953 – 2009

John receives a “Captain’s Word 
is Law” plaque from our father, 

Walter Rathbun.

Left: Agwbe, the 46’ 
steel ketch on which 
John and his family 
sailed around the 
world.

Above: John and his wife, 
Dominique.

Left: Their son, Colin, also 
a sailor.

At the age of 19, John bought his first sailboat and the sea became his home. Devoted to his wife, 
Dominique, and son, Colin, he accomplished what many only dream.

In Memoriam
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Introduction

Alpha Five - easy 
and powerful

What a good time I’ve had
writing this book! Larger screen
shots and almost a total rewrite,
it could be titled Alpha Five
Made Easier than Ever! We
hope you find it as exciting as

we do.

Bonus Pages
Every edition becomes larger and larger because the

folks at Alpha Software keep giving us more and more
features. The main book is restricted by the physical size
of the binding, but that hasn’t stopped us from giving our

all. We’ve added a PDF file with three more chapters!*

Here’s what’s in the Main Book:

•Chapter 1: Databases and Tables

•Chapter 2: Field Rules and Data Entry

•Chapter 3: Sets and Mapped Tables

•Chapter 4: Forms and Browses

•Chapter 5: Reports, Letters and Labels

•Chapter 6: Operations

•Chapter 7: Buttons, Hyperlinks and Bubbles

•Chapter 8: Finding, Sorting and Filtering Records

•Chapter 9: Checkboxes, Radio Buttons, Listboxes and 
Tree Controls

•Chapter 10: Graphics in the database

•Chapter 11: SQL and Alpha Five

•Chapter 12: Action Scripting, Xdialog and Custom 
Menus

•Chapter 13: Handy Things to Know

Here’s what’s in the Bonus Pages:†

•Chapter 14: Color and Style

•Chapter 15: Email and Fax with Alpha Five.

•Chapter 16: Alpha Four to Alpha Five, The Transition.

Alpha Five has always been in the forefront of database
products because it allows both non-programmers and pro-
grammers to develop sophisticated applications. You will

find Genies‡ everywhere. Action Scripting is easy to learn
and creates code in the background that is available for
further editing, if desired.

Whether you are an Alpha devotee or a new user,
Alpha Five will continue to amaze you with its ease of use.
Both novice and expert alike will love its features!

Francie’s back! 
Unfortunately, we had to drop Frances Peake’s chapter

on making the transition from Alpha Four to Alpha Five
last time, due to space considerations. We’ve had requests
for it and know there are still many out there who have yet
to change from their old reliable DOS friend to the Win-
dows version, so we have included it in the Bonus Pages.

What’s in Alpha Five Made Easy?
Mastering Alpha Five is truly made easy with this man-

ual. Designed as a tutorial with step-by-step instructions,
you will have, in just a short time, a basic understanding of
the program and will soon be developing your own custom
application. 

We started the Alpha Five Made Easy series with our
first book, based on Version 4.5, followed by revisions for
each new version up to this latest one. Our hard copy edi-
tion is produced in full color with a durable spiral binding
for convenience in learning and future reference. Copies
may be purchased at www.libertymanuals.com. A PDF
download is also available.

*. Bound, color copy available at www.LibertyManuals.com

†. Once you have installed the companion files, you’ll find them at c:\A5_Ver10Book\A5ME_Elec_Edition\BonusPages.pdf.

‡. Sometimes known as Wizards in other programs.



LESSON 1. INTRODUCTION
Getting Started

x

A message to the small business 
community
Welcome to an exciting way to control your informa-

tion. The database is a wonderful tool, yet, unfortunately,
many small business owners believe they must know how
to write code in order to create database applications.

Alpha Five has been our solution for many years.
You can design a simple database or a complicated one.

And you can do it without any knowledge of program-
ming. There is a programing language for those who want
to take advantage of it, but so much can be done with the
other Alpha Five tools that you will be amazed. If you do
want to continue your study by adding Xbasic to your
knowledge base, we now offer hard copies of Dr. Peter
Wayne’s book, Xbasic for Everyone.

I am a business owner, not a programmer, yet I
designed the Alpha Five databases which have been the
foundation of my businesses for many years. You’ve heard
it said repeatedly, “If I can do it, you can do it.” 

And it is true. I did. You can. Good Luck—and have
fun!

—Susan H. Bush
President, Liberty Manuals Company

Acknowledgments
As always, the assistance of my son and fulfilment

manager, David Hussey has been invaluable. Dave han-
dles the printing, assembly and shipping of our books.

Barry Ehrman has again proofed the exercises so that
your learning experience will be as trouble free as possi-
ble. Barry’s day job is professional photography. You can
check out his excellent work at www.barrystudios.com.

I wish to again express my gratitude to Frances M.
Peake for her contributions. Over the years since she first
worked in Tech Support at Alpha Software, Inc., many
users have benefitted from Francie’s knowledge. She was
the leader of the Miami Database User’s group for over ten
years. Together, we presented “GET INTO ALPHA FIVE!”
seminars for those wishing to learn to use Alpha Five and
Alpha Four users wishing to take their applications from
DOS to Windows. Be sure to visit her web site for more
tips — and I can’t recommend a better developer for both
desktop and web applications. Her web address is
www.proctorandpeake.com.

As we go to press
As I complete this book, an earthquake has just devas-

tated Haiti and our North Carolina snow that fell the week
before Christmas has yet to melt completely a month later.

The rare and extended freezing temperatures that we expe-
rienced have been felt in many parts of the nation and
abroad. The Winter Olympics in Vancouver are a bright
spot on the horizon.

 We continue to pray for our brave soldiers in Iraq and
Afghanistan and await their return home.

SHB. January, 2010

Getting Started

About ALPHA FIVE MADE EASY
ALPHA FIVE MADE EASY, The Basics and More for

Version 10, was developed to aid beginning and intermedi-
ate users in learning the basic concepts necessary to use
Alpha Five, but it doesn’t stop there. Persons experienced
in the use of Alpha Five will find many useful tips because
the book includes instructions on using the new features in
Version 10.

The lessons are designed as step-by-step instructions
for each section. While each section may be used indepen-
dently, some of the terminology builds sequentially from
lesson to lesson. For example, the Toolbox is described in
detail in Chapter 4. Subsequent lessons expect the user to
understand its function.

This manual does not cover all the features available in
Alpha Five. We invite the user to explore the program by
using the genies and the help file. The beauty of the soft-
ware is that it is so user friendly. Once you get started, you
will be amazed at the level of sophistication you are able
to achieve. 

The information in this book is current to Version 10.
Books on earlier versions of Alpha Five are available at
www.LibertyManuals.com.

What you need to know
You will need to have a working knowledge of Micro-

soft Windows and its standard commands. 

The equipment you will need to have
You will need to have the Alpha Five Version 10 pro-

gram installed on your computer. Information on purchas-
ing the program can be found at www.alphasoftware.com.
You may also contact Alpha Software, Inc. by E-mail at
(custserv@alphasoftware.com) or by phone at 781-229-
4500 during regular business hours, Eastern Time. For fur-
ther information on contacting Alpha Software, Inc., see
page 483.
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Footnotes
In some instances, the footnote for a given page will

appear at the bottom of the following page. Location of
footnotes is set by my excellent book writing software pro-
gram (Adobe Framemaker) and I have no control over
where it puts them!

Tips on searching the Help files
Throughout the book, we have provided locations of

Alpha Five help topics* so that you can find additional
information on a given subject. You can access them from
the file on your local computer and from the web files at
alphasoftware.com. 

1. Open Alpha Five and choose Help > Help
Source.

 The options are:

• Web Help and Local Help.

Our references are to the Local Help version because
its format remains constant and we like it better when
working in the desktop. We work with the Contents, Index
and Search tabs visible in a frame to the left of the topic
page. 

•The top left button toggles between Show and 
Hide. If the tabs are hidden, click Show. 

• Contents Tab: Most of the help references in this 
book come from the Contents tab as seen in the fol-
lowing example. 

• A5 Help > User Guide > Databases > Creating 
Tables.

• Index Tab: Another quick way to find information is 
to use the Index tab and type in a topic. When neces-
sary, we have listed some of the references this way 
because we can’t tell exactly where the page can be 
found at the Contents tab. An example is:

•Alpha Five Help > Index tab: Enter Image File 
Reference > Adding an Image. (The final ref-
erence, Adding an Image, is the page that I 
found helpful.)

• Search Tab: When all else fails, we go to the Search 
tab and list the reference that way.

WHAT’S NEW HELP

2. At the above menu, scroll down to:

• What’s new in Version 8 describes the enhancements 
for that edition. 

• What’s new in Versions 9 & 10 contain the 
help files for those versions. 

•At this writing, these files have not be inte-
grated into the main help file. For example, 
Super Controls were developed in V9 and new 
ones were added in V10. They are only 
described in these What’s new files.

•You may find it worth the time, ink and paper to 
print them out and note the contents for future 
reference.

•  The good news is that there are also 
videos. We have noted several in the instruc-
tions. Look for this video camera icon.

*. The Alpha Five Help files may be edited at any time. Our entries are current to the time of their entry in this book.
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To quote or not to quote
Within Alpha Five, quotes have a very specific use. To

avoid confusion in the instructions, we have not used
quotes around text to be entered, but have bolded the font
instead. For example: Type My name is Susan. 

About the screen shots
There are more screen shots in this book than ever

before, and they are LARGER than before! I have several
readers to thank for that. Two in particular come to mind.
One who was more than a little cranky and one who
couldn’t have been nicer. The second even told me about a
screen shot capturing tool (Snagit by Techsmith) that I can
no longer live without.

Somewhere in the middle of this edition, I learned that
I could make screen shots appear next to the copy, rather
than only below it. I’ve used Adobe Framemaker since the
very first edition of these books, but I just didn’t know
how to present decent sized images without wasting paper.
When the light bulb came on — the feature was there all
the time — I went back and revised the earlier work, too.
I’m sure you’ll agree that the results have been worth the
extra time it has taken to get this book into your hands. Of
course, you are the ultimate judge, so if you find any that
don’t work, please give me the page and I’ll see what I can
do for the next edition.

Using Alpha Five with a remote 
database

One of the very impressive things about Alpha Five is

that it allows users of SQL* and other database file types
to connect Alpha Five to their information. The data
remains in its original format, but now Alpha Five’s leg-
endary easy-to-use form design and other fabulous fea-
tures are available for everyone! Chapter 11 tells all about
it. 

For the most part, learning Alpha Five is the same for
both SQL and DBF users, so the DBF companion files
included with this book are appropriate learning tools for
all.

Making the transition from Alpha Four 
to Alpha Five

As stated earlier, this edition of Alpha Five Made Easy
includes Frances Peake’s excellent explanation on the

transition from Alpha Four† to Alpha Five. Look in the

Bonus Pages.

Installing the ALPHA FIVE MADE 
EASY lesson files

Note: The Alpha Five program is necessary to open the
files. See above for information on purchasing the pro-
gram.

All Windows Platforms

Insert the ALPHA FIVE MADE EASY, The Basics
and More for Version 10 companion CD-ROM in your
CD drive. 

• In most cases, the installation will begin automati-
cally. 

If that is not the case, the following instructions will
show you how to begin the installation:

A. Begin at the Windows Desktop. Follow instructions 
below for your Windows platform.

Windows Vista & Windows 7

We regret that at this time we do not have access to
Vista or Windows 7. You can, however, follow the basic
instructions for Windows XP. We hope the only difference
is that things may be in slightly different places.

Windows XP

1. Choose Start > Control Panel.

2. Double click ADD OR REMOVE PROGRAMS.

3. Click ADD NEW PROGRAMS (left pane).

4. Add a program from CD-ROM or floppy disk: (Click
CD or FLOPPY) (Click NEXT)

•Windows searches available drives for the install.exe file.

•Continue at Step C below.

Windows 2000

1. Choose Start > Settings > Control Panel.

*. SQL = Structured Query Language. This is the format used by Microsoft Access and some other databases, as opposed to the DBF 
file format used by Alpha Five.

†. Alpha Four is the DOS version of the database.
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2. Double click ADD/REMOVE PROGRAMS.

3. Click ADD NEW PROGRAMS (left pane).

4. Add a program from CD-ROM or floppy disk: (Click
CD or FLOPPY) (Click NEXT)

•Windows searches available drives for the install.exe file.

•Continue at Step C below.

Windows 98

1. Choose Start > Settings > Control Panel.

2. Double click on Add/Remove Programs.

3. Click Install.

4. Click Next.

•Continue at Step C below.

B. Windows reports the command line for the installation 
program.

• If the install.exe file does not appear in the “Open” window, 

•Click Browse.
•Navigate to the drive containing the CD.

•Double click on Install.exe.
C. Windows then reports the command line for the installa-

tion program in the “Open” window.

5. Click Finish.

•Message reads: This will install the Alpha Five Made Easy 
files to your hard drive.

6. Click OK.

7. Unzip to folder: c:\A5_Ver10Book. (Click Unzip)

•Note: The Operations in Chapters 6 and 7 are set to locate 
files placed in the above location. If you move the files in a 
different location, you will need to make adjustments to the 

Import Operation.*

8. Files unzipped successfully. (Click OK)

•The Readme file opens.

9. After reading the Readme, close it and the Control
Panel.

Database files
There are five databases included with this book.

• ABC_v10_Lessons is the foundation for most of the 
exercises.

• NorthwindCopy is for remote database users and is 
used in Chapter 11, “SQL and Alpha Five.” 

• A4_Data, A5_Apps and A5_Trans are for the transi-
tion from Alpha Four to Alpha Five.

The databases include both practice exercises and fin-
ished examples. 

• Beginners, will find the practice exercises the best 
way to learn Alpha Five. Just follow the step-by-step 
instructions.

• Experienced users can follow the step-by-step 
instructions to learn new techniques or use the fin-
ished examples to quickly sharpen their skills. 

Naming convention
The included Alpha Five databases contain sample and

working tables, reports, etc. When the exercise calls for
you to create or open a file there is usually a correspond-
ing completed example. 

• The exercises will call for you to create a file begin-
ning with “My,” such as MyClientInfo.

• The exercises will call for you to open an existing a 
file ending with “Practice,” such as StylesheetPrac-
tice.

• The completed examples do not have the “My” prefix 
or “Practice,” such as ClientInfo or Stylesheet.

Troubleshooting tip: If you are having difficulty with
an exercise, you can open the completed example to see
the finished example in action.

Remember the Bonus Pages!
They are on the CD or in the Electronic Download Edi-

tion and will be loaded when you install the companion
files. In most cases they can be found at:

c:\A5_Ver10Book\A5ME_Elec_Edition\
BonusPages.pdf

*. See “Caution!” on page 272.



LESSON 1. INTRODUCTION
Support

xiv

Support

While every effort has been made to provide readers
with a trouble free and accurate learning experience, some
errors are bound to occur.

The support section of the website will publish correc-
tions as they are discovered. We suggest you visit it peri-
odically to see if there are modifications.

And please let us know if you find something. Your fel-
low readers will appreciate it!
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 Chapter 1. 

Databases and Tables

From paper to power. 

Choose your file type - DBF or SQL. Alpha Five is the database for non-programmers
and experts alike. Its ease of operation allows even those previously inexperienced to con-
vert paper to electronic power. Its Xbasic programming language sends developers on a
quick, easy path to further customizing.
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Creating a new database

• In this exercise, we will create a new database and enter a table into that database.

VERY IMPORTANT! Be sure to put each database in its own folder. Many files will be created and
you don’t want them mixed up with the Alpha Five program files.

1. Start Alpha Five Version 10 from the

Start menu or the program icon.

•There are 2 tabs on the opening screen.*

•News & Updates

•Databases & Tasks

2. Tab: News & Updates: This screen is actu-

ally a web page.† It reports new information
from Alpha Software and gives helpful links.
If your software is out of date, you will get a
warning in a red box with a link to download

the latest patch.‡

•You can also access the download files from 
within Alpha Five: From the Top Menu, choose 
Help > Download patches.

3. Tab: Databases & Tasks. Click Cre-
ate a new, empty database.

•If you don’t see the above screen, open 
Alpha Five; choose File > New Database.

4. Click OK at the following screen.

5. At the Create New Database win-
dow, navigate to the
c:\A5_Ver10Book\ folder.

6. Create and open a new folder** with
the following name:

c:\A5_Ver10Book_MyNewDB.

*. This screen is sometimes referred to as the Welcome Screen.

†. As in many other instances, this screen is dynamic, meaning it may change from time to time depending on your most recent update. 

‡. Updating always follows the same procedure: 1. At the Alpha website, choose the appropriate file for your software edition. 2. 
Download. 3. Before running, close Alpha Five—not always required, but a good practice. 4. Follow instructions.

**.Putting the database in its own folder is very important. 
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a. To make a new folder, click the Create New Folder button.

b. Over type New Folder with the new name (step 6 above) (Press 
ENTER)

c. Double click the folder to open.

7. File Name: Enter the name of the database.

A5_Basics

8. Click Save.

•The database is created and the Alpha Five Control Panel appears.

Understanding Tables and Fields

PLEASE TAKE A MOMENT TO 
READ THIS

Tables are composed of 15 types of fields. 

•Character

•Numeric

•Date

•Logical

•Time

•ShortTime

•ExponentNumeric

•Memo

•Bitmap

•OLE

•Rich Text Memo

•JPeg Image

•Image File Reference

•HTML Memo 

•UUID 

CHARACTER The most common field type, it holds alphanumeric data. Character fields may con-
tain letters and numbers.

When you are planning to store numbers in a field, consider the following:

•Character fields can show leading 0’s. [For example, Zip Code= 07760] 
Numeric fields can not.
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•Character fields can have both letters and numbers [C 0556]. Numeric fields 
can not.

•Character fields can have other symbols: [Phone = (732) 842-3000] Numeric 
fields can not.

For some character fields, the width is arbitrary, such as first name, company, city,
etc. Others, such as phone numbers and zip codes are determined by the complete num-
ber of characters they will hold. For example, in the next lesson, we will use field rules
to set up phone numbers to be viewed as (732) 842-3000 (14 characters) and zip code as
07760-0453 (10 characters).

NUMERIC Fields on which you might want to perform calculations. Numeric fields accept only
numbers and the decimal point.

•When planning the width of a numeric field, include the decimal point, deci-
mal places and one extra space for a minus sign, even if you do not plan to 
enter negative numbers. For example, if the largest number you plan to store 
in a field is 9999.99, make the field width 8 with 2 decimal places.

•In the Form and Report editors, you will be able to format numbers to display 
dollar signs ($500.00) and commas (400,000.00).You will be able to show 
fewer decimals on reports, forms, etc. than created in Structure Table, but not 
more. 

•For example, a field structured at 4 decimals could read 400.9099 on a report. 
It could also be set to 2 decimals at the report level, in which case it would 

round to 400.91.* 

DATE This field type only accepts valid dates. It is aware of the calendar, including leap
years. Automatically set to a width of 8. See “Enter Date Field” on page 28 and “Using
Rich Text objects” on page 160.

LOGICAL Contains one character, which is used to represent a TRUE or FALSE value.

TIME Shows date and time. This field type only accepts valid time format. Automatically
set to a width of 17. See “Using Rich Text objects” on page 160.

•11/30/2005 12:00 00 pm 

SHORT TIME This field type only accepts valid time format. Automatically set to a width of 9. See
“Using Rich Text objects” on page 160.

•12:00 00 pm

EXPONENT NUMERIC A fixed precision decimal number.

MEMO A 10-character width is automatically created. In actual use, the field expands. The
only limit to the number of characters is available disk space. 

•Formatting of characters not available. (see Rich Text Memo below.)

BITMAP Stores bitmap (.BMP) pictures as data in the table.

OLE Used to link a document, such as a spreadsheet or graph, using the OLE method. 

*. The ROUND function is also available to round decimals to a certain number in calculations. See A5 Help > Index Tab > Keyword: 
Round. We’ll talk lots more about functions as we work through the book.
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RICH TEXT MEMO This is the second type of memo field available. It, too, is automatically set to a
width of 10. It differs from the Memo Field in the following manner:

•Paragraph formatting is available.

•Character formatting, such as bold, underline, color, etc., is available. 

•Fields can be inserted.

JPEG IMAGE Stores JPEG (.jpg) pictures as data in the table. JPEG files are much smaller than
bitmaps. Bitmaps may also be stored in JPEG fields. When bitmaps are stored here, they
are automatically converted to JPEG files.

IMAGE FILE REFERENCE This field type is also called a “linked image field” because the image is not stored
directly in the database. Only the reference is stored. Since graphics files can be quite
large, using links can result in a significantly smaller database. To learn how to enter
references, go to A5 Help > User Guide >Index tab > Enter: Image File Reference Con-
trol (Form) > Choose: Placing on a form.

HTML MEMO This is the third type of memo field available. It, too, is automatically set to a width

of 10. It allows access to the HTML* Editor where web pages can be created and stored

in the database, using either WYSIWYG† or HTML.

UUID This field returns a UUID (Universally Unique Identifier), similar to a GUID (Glob-
ally Unique ID). It is intended for advanced SQL users. An example might be

{fj56co90-et23-r5i6-564w-rr45-rk34rbl5}.‡

HINT! If you plan to move your database from one drive to another, it is a good idea to set
up Aliases in order to maintain links. (See “Understanding Aliases” on page 461.)

In planning tables, keep the following in mind:

•The width set for a field governs the size of the table because space is 
reserved even if the field is empty or partially filled.

GO TO ALPHA 5 HELP In this series of lessons, we will use the following field types: Character, Numeric,
Date, Logical, Memo, Rich Text Memo, JPEG Image and HTML Memo. To learn about
the other types and more about fields in general, see A5 Help > Alpha Five User Guide
> Databases > Creating Tables. (For more information on using the help file, see “Tips
on searching the Help files” on page x.)

Creating a new table

1. On the Alpha Five Control Panel, click the Tables/Sets tab.

2. Click the New button.

PLEASE TAKE A MOMENT TO 
READ THIS

There are several methods for creating a table.

• The first three, Design mode, Text mode and by Example are intended for Alpha 
Five users.

*. HTML: Hypertext Markup Language. This is the code for writing web pages. 

†. WYSIWYG: What You See Is What You Get. Even the uninitiated can create web pages by entering text and/or pictures in the 
HTML Editor. The code is created in the background and can be seen at the Source tab.

‡. Alpha Five also has an easy-to-use feature that provides a unique ID for each table. (See “Defining Auto Increment fields” on 
page 23.)
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• The next two, Passive-Link and Active-Link, are for remote database users.*

• Mapped Tables are discussed in “Understanding Mapped Tables” on page 56. on 
page 56.

•  A Set is a combination of tables and is discussed in Chapter 3.

•  Create using Genie (at the bottom of the list) has some interesting pre-designed 
tables for certain pursuits such as Artists, Home Inventory, Invoice Header and 
Line Items. You may want to look at the selection to see if it could be useful to you.

• Click the Preview button to see the fields in the table.

In addition, the “New” button accesses two methods for importing text into tables.

•Import from SQL Database.

•Import from ASCII File.

We will use the classic method, Design mode because it best illustrates the principles
of table design.

GO TO ALPHA 5 HELP Once table design is understood, you may wish to experiment with the other styles.
To see them illustrated, go to A5 Help > User Guide > Databases > Creating Tables >
Create a New Table, Create a New Table from Sample Data and Create a New Table by
Example.

3. Choose New Table (Design mode)
from the drop down list.

•Be sure the Tables/Sets tab is active.

•The Create Table window appears:

•This is where fields are created. 

4. Click in the Type field and open the
selection box to see the choices.

HINT! Since the field types all begin with a different letter, pressing the first letter will
quickly insert the type. For example, pressing C will select Character.

WINDOWS HINT! For quick keyboard access to drop down lists such as the list of field types, use ALT
+ DOWN ARROW. This will work in all Windows applications.

• Next, we will set up the table.

5. Click in the first entry box of the Name column.

6. Enter the fields as follows:

•Press TAB to navigate between cells.

NOTE Notice that Alpha Five replaces the spaces in field names with underscores. That is,
First Name becomes First_Name. The case is also set by the program, so first name
will also become First_Name after you save the table.

*. See Chapter 11, “SQL and Alpha Five” on page 383.
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The last column, Indexed?, is discussed on page 317. No entry is necessary at this
time.

7. Save the table:

• There are three ways to save in Alpha Five. All are common Windows commands:

a. Choose File > Save.

b. Press CTRL + S.

c. Click the Save button at the upper left of the screen.

BASIC SKILL: *CTRL + S We prefer CTRL + S because it’s faster and will use this method in our lesson
instructions. You may prefer to use a different method.

•The Specify Table Name 
window opens.
The left window lists the
tables in the current database.
This will help you in locating
a unique name for your new
table. Since this is the first
table in the new database, the
left window is empty.

•By default, the table will be 
saved in the same folder as the 
database.

Name Field Type Width Decimal

Client ID Character 5 0

Enter Date Date 8 0

First Name Character 12 0

Middle Initial Character 2 0

Last Name Character 20 0

Company Character 35 0

Address 1 Character 25 0

Address 2 Character 25 0

City Character 25 0

State Character 2 0

Zip Code Character 10 0

Phone Character 14 0

Fax Character 14 0

E-mail Character 30 0

Website Character 40 0

Notes Memo 10 0

*. Basic Skills are preferred methods and will be used throughout this book.
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8. Type in the file name: Clients. (Click OK)

•After saving, you are returned to the Restructure Table window.

9. Click the X in the upper right of the dialog to exit.

•The newly created table appears in the list.

•This table has only 3 types of fields: Charac-
ter, Date and Memo. 

•To see other types of fields and further explore 
the Control Panel, we will close this database 
and open the ABC_Seminars database, the basis 
for most of the lessons in this book.

Closing the database
You can close the database in several ways. The first two of the following methods

also close Alpha Five. The third keeps Alpha Five open, but closes the current database
and opens a different one.

•Click the EXIT button when you are at the Alpha Five Control Panel.

•Click the X in the upper right corner of the Alpha Five window.

•Switch to another database as we will do in the next exercise.

Opening multiple databases
You can have more than one Alpha Five database open at one time by opening

another instance at the Windows Start Menu or by clicking on the program icon on the
desktop.

Understanding the Alpha Five Control Panel

PLEASE TAKE A MOMENT TO 
READ THIS

The Alpha Five Control Panel is its main menu and the heart of Alpha Five design. It

lists the Tables, Sets, Forms, Browses, Reports, Letters, Labels,* Operations and Codes

that have been created for the database.†

• This exercise continues from the previous one. The A5_Basics database is still 
open. We will now switch to another Alpha Five database and the first will close 
automatically.

• You can also open this database directly from the Alpha Five opening screen.

1. Top Menu: Choose File > Open Database.

2. Navigate to c:\A5_Ver10Book\ABC_V10_Lessons\ABC Seminars 
(alpha5 Document).

3. Click Open.

•The database opens at the ABC Seminars menu.

*. Envelopes may also be made at the Labels tab.

†. Depending on the version of Alpha Five that you are using, additional tab(s) may be shown. This manual covers only the tabs men-
tioned above. All tabs are covered in this book
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Taking a tour*

4.  Click on the Control Panel tab in the Window Bar at
the bottom of the screen to bring the Control Panel to the front.

5. On the Alpha Five Control
Panel, choose the Tables/Sets
tab.
    When you install the Alpha Five
program, the database objects will
appear as large icons, as shown in
the following illustration. We rec-
ommend changing the view so
that you can see more objects and

get more information about them.†

6. Click Detail View, the last graphic
to the right (in orange at left).

•The full name of the path and the date 
last modified is now shown next to the 
name of the Table or Set.

CONTROL PANEL TABS

•The tabs are: Tables/Sets, Forms, 
Browses, Reports, Letters, Labels, 
Operations and Code.

If you do not see these tabs on
the Alpha Five Control Panel

a. Right-click on any tab.

b. Be sure that the Layouts is unchecked.

c. Choose the tabs to match the list 
above.

TABLES/SETS TAB When developing a database, you can use the Tables/Sets tab as a take-off point for
most design tasks.

In this section, we will use the right-click menus frequently. You can also access
Alpha Five’s features by choosing from the menu bar and toolbars at the top of the
Alpha Five program window.

• The tables are identified by a single box icon. (The triple box icons are for sets, 
which will be discussed in a later chapter.) Following the instructions below, exam-

*. Excerpted from Alpha Four to Alpha Five: The Transition, by Frances M. Peake, 2008. Available as a PDF download at www.proc-
torandpeake.com and www.libertymanuals.com.

†. Depending on how Alpha Five was last opened, your screen may show a different view.
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ine each table closely and review the fields; we will be referring to them often. The 
tables in this database use numeric, date, logical and rich text fields.

LAYOUTS TABS The layouts tabs are: Forms, Browses, Reports, Letters and Labels.
• Use these tabs to:

•Create and save new layouts

•Edit, view and delete existing layouts

•Preview and print layouts 

OPERATIONS TAB Operations perform tasks on groups of fields, records and tables and can be saved for
future use.

Changing the table structure

You can add and remove fields and reorganize their positions. You can also change
the size of a field, but be careful about making it shorter, because you could loose exist-
ing data.

CAUTION These tables are the basis of most of the exercises in this book. Do not save any

changes unless instructed to do so.*

1. Tables/Set tab: Right click on the clients table. 

Acts on: Action

Fields: Convert case of fields (For batch operation of imported or changed 
records. Most case conversion is done in Field Rules (see page 24).

Records: Append records from one table to another

Convert case of fields

Copy records to a new table

Cross-tabulate records

Delete, mark or unmark records

Delete, mark or unmark duplicate records

Export records

Import records

Intersect or subtract records by comparing two tables

Post records from one table to another

Query, search and replace records

Summarize records to a new table

Update records

Tables: Join tables

*. The tables can be restored to their original state by reinstalling the files from the CD or download file.
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•The right click menu opens.

BASIC SKILL: RIGHT-CLICK MENUS

Alpha Five uses Right Click Menus
extensively. When you’re looking for
something, just right click—it might be
right in front of you!

2. Choose Edit Structure... from
the options.

•The Restructure Table dialog opens.

WARNING MESSAGE
After you make changes, you will get a warning about changing
the table structure. If you are confident about your modifica-
tions, click Yes accept the alert.

3. Don’t make any changes, just close the Restructure
card by clicking the X in the upper right corner of the
window.

Planning table design
It is important to note that disc space is reserved for each field in the table, whether

the field is filled fully, partially or not at all. While not the issue it once was because
database files are relatively small in relation to today’s large hard drives, it still makes
sense to make fields large enough to hold the data, but not overly large.

 Don’t create an elephant when a mouse will do.

Naming your database and its objects*

PLEASE TAKE A MOMENT TO 
READ THIS

There are certain considerations in naming the database and the tables, sets, forms,
etc., of which it is composed. Frances M. Peake has outlined the best procedure, based
on her many years as a professional database developer. 

USING LONG NAMES Use long names - but not too long.

•Make names long enough to be helpful, but not too long. If you use a lot of 
long names, you risk running out of space when defining a calculated field 
expression, for example.

*. Excerpted from Alpha Four to Alpha Five: The Transition, by Frances M. Peake, op cit.
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•Also, space for displaying fields and file names is limited on some of Alpha 
Five’s windows, dialog boxes and genies. If you use very long names, you 
may not be able to see the entire name on the screen.

AVOIDING SPACES Avoid spaces and special characters

•Avoid using spaces and characters other than A-Z, 0-9 and _ (the underscore) 
in names. There are a few places in Alpha Five that seem to have difficulty 
interpreting spaces and special characters. Further, it is easier to refer to 
objects in Xbasic when they do not have spaces.

RESERVED WORDS Avoid using names that are already used by Alpha Five, such as file, field, or email.

•Alpha Five will rename these illegal object names for you on form and report 
layouts, but Xbasic may have difficulty interpreting them correctly. Instead 
of file, field, or email, use more distinct names such as file_num, 
field_of_study and cust_email. 

SELECTING NAMES Be descriptive when choosing the names. 

•When naming layouts (forms, reports) and saved operations (queries, 
updates), be descriptive and refer to the table or set it is based on. For exam-
ple, name the data entry form for clients “Client” or “ClientEntry”, not sim-
ply “DataEntry.”

• Alpha Five scripts refer to database objects by name only. This is another reason to 
differentiate names of objects of the same type.

Using a naming convention
Use a naming convention that will keep similar objects organized alphabetically.

Adopt a formal one or devise your own at the beginning of the development process and
be consistant.

A widely accepted naming convention for databases is the Leszynski Naming Con-
vention or Hungarian Notation. A web search will direct you to numerous articles on
this subject. You can adopt—or adapt—one of these or devise your own at the begin-
ning of the development process.

Incorrect – One of these forms is 
for Clients and the other is for 
Registration, but how would you 
know?

Correct – At a glance, you will 
know on which table the form is 
based.
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Opening an existing database

PLEASE TAKE A MOMENT TO 
READ THIS

Follow this procedure any time you want to open an existing database when (A)
Alpha Five is closed, (B) if the Databases/Tasks screen does not appear or (C) if Alpha
Five is already open.

A. When Alpha Five is closed.

1. Start Alpha Five from the Start menu or the program icon.

2. Tab: Databases & Tasks:

FILE IN LIST • If you have previously opened the existing database, it should appear on the list. 

3. Highlight a selection (red box
above) to view its path (below the
Recent Database list window).

FILE NOT IN LIST • To open a database that is not on the list:

a. Click Open an existing database.

b. Choose More Databases (blue box above). (Click OK)

c. At the Open Database window, navigate to the desired folder.

d. Click on the file with the tiny Alpha Five logo next to it 

•File type: alpha5 document.

•If you have put each database in its own folder there will be only one 
such file.

•The next time you open Alpha Five, the database should appear on the Data-
bases/Tasks list.

•The ones most recently used will be at the top of the list.

EDIT LIST You can clean up the list if it gets long and you want fewer recent databases to show.

a. Click Edit List (green box above).

SAMPLE DATABASES Also listed are a group of databases that are shipped with Alpha Five. These are
excellent learning tools. On most computers, they may be found in the c:\Program
Files\A5V10\Samples folder.

B. When Alpha Five is closed and there is no Databases/

Tasks screen:*
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•Begin at step 1 following. (If a database is already open, this method opens a 
2nd instance of Alpha Five.)

C. When Alpha Five is already open.

•Start at step 2 following. (If a database is already open, this method closes the 
first and opens the second in its place.)

1. Start Alpha Five from the Start menu or the program icon.

2. Choose File > Open Database.

3. Navigate to the database as directed in the lesson. (Click Open).

You may close the database or leave it open if you are continuing to 
the next chapter.

Congratulations!

You now have the skills necessary to create a database and the tables of
which it is composed.

Summary New databases are defined at the Databases & Tasks tab of the Welcome Screen or
by choosing File > New Database when the program is open. 

Putting each database in its own folder is critical because many files are created for
each and it would be chaos to have them mixed in with the program files or those of
another database.

An existing database is opened at the Databases & Tasks tab or at File > Open Data-
base from within the program.

The Control Panel is the hub of the program.
A database is composed of tables. Tables are composed of 15 types of fields. 
Tables are created by clicking the New button on the Alpha Five Control panel.

Tables are edited by right clicking on the table and selecting Edit Structure.

• Functions and Expressions covered in this section:

•ROUND: Rounds calculation to the specified decimal point (see footnote on 
p. 5).

*. The developer is given the option to keep the Databases/Tasks screen from appearing. To turn them on or off, go to “Turning the 
welcome screen on and off” on page 459.
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The Basics and More for Version 10 

 How to design your database without code. 
 How to enhance your application with images. 
 How to create fantastic forms and rockin’ reports. 
 How to create dynamite dialog boxes. 
 How to use Alpha Five with your SQL database. 
 And more, more, MORE! 

 This is the book you’ve been looking for—The easy way to learn the most user-friendly database appli-
cation program and out there! New or experienced, you will find many tips for a successful application.  

Frances M. Peake, professional database designer and co-owner of Proctor and Peake, Inc., enthusiastically en-
dorses Alpha Five Made Easy and answers a question about Alpha Five. 
 

“The plain-English explanations of each Alpha Five feature in this book show Susan's 
experience applying the program in a real-world business environment. Readers will find 
every chapter full of valuable information, regardless of their experience level. On behalf 
of Alpha Five users and enthusiasts everywhere, thank you Susan, for writing this 
book!” 

 

 “With regards to Alpha Five, we are long time Q&A users and have been looking for a replacement that is easier than Access, 
dBase, etc., but has the power to write strong applications without a lot of coding. Is Alpha Five the product we are looking for?  
I would appreciate your opinion.”                                                                                                                                         — RADeV, 
Jr. 

 “You indicate that you are looking for “the power to write strong applications without a lot of coding.” In that case, yes, Al-
pha Five is a better choice than Access. I develop applications in both and I tell you that you can go so much farther in Alpha Five 
without having to do programming. In fact, you may not have to do any coding at all. Alpha Five offers a lot of commands and 
properties that simply do not exist in Access, where you would have to write your own procedures and functions to do the same 
thing. 

  “Even when you need to automate a process, Alpha Five has a number of alternatives to writing code, such as  “Action Script-
ing” that lets you perform the steps you want to automate and generates the code for you. There are, of course, some things that 
you might dream up that will require writing code in Alpha Five.”                                                                                    — FMP 

The equipment you will need to have to use this book: 
 You will need to have the Alpha Five program installed on your 

computer. Information on purchasing the program may be found 
at www.alphasoftware.com.± 

 Alpha Five Version 10 contains full design features for both 
Desktop and Web Applications and SQL users. See www. 
AlphaSoftware.com for details. 

 A companion CD containing the working databases for the book 
is included with this manual. 

BOOKSHELF CATEGORY: 
ALPHA FIVE/DATABASE/SOFTWARE 
Liberty Manuals are published by  
Liberty Manuals Company, PO Box 453, Rumson, NJ 07760.  
1-732-842-3000 

LIBERTY 
MANUALS 

USA $69.95 
www.LibertyManuals.com 

± Liberty Manuals Company is a separate 
company from Alpha Software Inc.  
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